aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-07 18:28:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-14 22:30:56 +0000
commit28fa3044d5e978de5801cf9fa02ae596e9ebc833 (patch)
treea5605da733056815c3444e5b1e275c907438bfe1 /meta/recipes-devtools/automake
parentf5e681d8677d7dd528cc316e937ff186ede8ca9a (diff)
downloadopenembedded-core-contrib-28fa3044d5e978de5801cf9fa02ae596e9ebc833.tar.gz
automake: Remove delays in configure scripts using automake
By default automake puts "sleep 1" into the start of configure scripts which adds pointless delays to them. Rather than do this, lets just assume our systems are sane. Since this means our patches touch m4 files, we need to stop automake running autoreconf so we tweak the do_configure to avoid this. (From OE-Core rev: 25eca6793cd4ad7af7e23669ed4f47d075ec696d) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake')
-rw-r--r--meta/recipes-devtools/automake/automake.inc3
-rw-r--r--meta/recipes-devtools/automake/automake/performance.patch73
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.bb3
3 files changed, 78 insertions, 1 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index a1debd8d53..4f9b5f7740 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -10,6 +10,9 @@ SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.gz"
inherit autotools texinfo
do_configure() {
+ # We can end up patching macros, which would then mean autoreconf
+ # Cheat by saying everything is up to date.
+ touch ${S}/aclocal.m4 ${S}/Makefile.in ${S}/configure
oe_runconf
}
diff --git a/meta/recipes-devtools/automake/automake/performance.patch b/meta/recipes-devtools/automake/automake/performance.patch
new file mode 100644
index 0000000000..3e6d5694dc
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake/performance.patch
@@ -0,0 +1,73 @@
+By default automake puts "sleep 1" into the start of configure scripts
+which adds pointless delays to them. Rather than do this, lets just assume
+our systems are sane.
+
+RP
+2015/12/7
+Upstream-Status: Inappropriate
+
+Index: automake-1.15/m4/sanity.m4
+===================================================================
+--- automake-1.15.orig/m4/sanity.m4
++++ automake-1.15/m4/sanity.m4
+@@ -23,60 +23,5 @@ case $srcdir in
+ AC_MSG_ERROR([unsafe srcdir value: '$srcdir']);;
+ esac
+
+-# Do 'set' in a subshell so we don't clobber the current shell's
+-# arguments. Must try -L first in case configure is actually a
+-# symlink; some systems play weird games with the mod time of symlinks
+-# (eg FreeBSD returns the mod time of the symlink's containing
+-# directory).
+-if (
+- am_has_slept=no
+- for am_try in 1 2; do
+- echo "timestamp, slept: $am_has_slept" > conftest.file
+- set X `ls -Lt "$srcdir/configure" conftest.file 2> /dev/null`
+- if test "$[*]" = "X"; then
+- # -L didn't work.
+- set X `ls -t "$srcdir/configure" conftest.file`
+- fi
+- if test "$[*]" != "X $srcdir/configure conftest.file" \
+- && test "$[*]" != "X conftest.file $srcdir/configure"; then
+-
+- # If neither matched, then we have a broken ls. This can happen
+- # if, for instance, CONFIG_SHELL is bash and it inherits a
+- # broken ls alias from the environment. This has actually
+- # happened. Such a system could not be considered "sane".
+- AC_MSG_ERROR([ls -t appears to fail. Make sure there is not a broken
+- alias in your environment])
+- fi
+- if test "$[2]" = conftest.file || test $am_try -eq 2; then
+- break
+- fi
+- # Just in case.
+- sleep 1
+- am_has_slept=yes
+- done
+- test "$[2]" = conftest.file
+- )
+-then
+- # Ok.
+- :
+-else
+- AC_MSG_ERROR([newly created file is older than distributed files!
+-Check your system clock])
+-fi
+ AC_MSG_RESULT([yes])
+-# If we didn't sleep, we still need to ensure time stamps of config.status and
+-# generated files are strictly newer.
+-am_sleep_pid=
+-if grep 'slept: no' conftest.file >/dev/null 2>&1; then
+- ( sleep 1 ) &
+- am_sleep_pid=$!
+-fi
+-AC_CONFIG_COMMANDS_PRE(
+- [AC_MSG_CHECKING([that generated files are newer than configure])
+- if test -n "$am_sleep_pid"; then
+- # Hide warnings about reused PIDs.
+- wait $am_sleep_pid 2>/dev/null
+- fi
+- AC_MSG_RESULT([done])])
+-rm -f conftest.file
+ ])
diff --git a/meta/recipes-devtools/automake/automake_1.15.bb b/meta/recipes-devtools/automake/automake_1.15.bb
index c33dc22679..4f280ba8c3 100644
--- a/meta/recipes-devtools/automake/automake_1.15.bb
+++ b/meta/recipes-devtools/automake/automake_1.15.bb
@@ -20,7 +20,8 @@ RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
SRC_URI += " file://python-libdir.patch \
file://py-compile-compile-only-optimized-byte-code.patch \
- file://buildtest.patch"
+ file://buildtest.patch \
+ file://performance.patch"
SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"