aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.15.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-07-12 03:15:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 13:48:59 +0100
commit6455aa2289a401ab4959b399acada02907be99be (patch)
tree8121b716762b795ab41c02d06ed4be0428111f30 /meta/recipes-devtools/automake/automake_1.15.1.bb
parent20c1209f6fe0d56aa3698583a1b6d2774fbf4401 (diff)
downloadopenembedded-core-contrib-6455aa2289a401ab4959b399acada02907be99be.tar.gz
automake: 1.15 -> 1.15.1
* Remove backported patch: - 0001-automake-port-to-Perl-5.22-and-later.patch Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.15.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.15.1.bb b/meta/recipes-devtools/automake/automake_1.15.1.bb
new file mode 100644
index 0000000000..481234185e
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.15.1.bb
@@ -0,0 +1,42 @@
+require automake.inc
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS_class-native = "autoconf-native"
+
+NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
+
+RDEPENDS_${PN} += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-data-dumper \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-thread-queue \
+ perl-module-threads \
+ perl-module-vars "
+
+RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
+RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
+
+SRC_URI += "file://python-libdir.patch \
+ file://buildtest.patch \
+ file://performance.patch \
+ file://new_rt_path_for_test-driver.patch \
+ file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
+ "
+
+SRC_URI[md5sum] = "95df3f2d6eb8f81e70b8cb63a93c8853"
+SRC_URI[sha256sum] = "988e32527abe052307d21c8ca000aa238b914df363a617e38f4fb89f5abf6260"
+
+PERL = "${USRBINPATH}/perl"
+PERL_class-native = "${USRBINPATH}/env perl"
+PERL_class-nativesdk = "${USRBINPATH}/env perl"
+
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
+
+do_install_append () {
+ install -d ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native nativesdk"