summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-07 18:28:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-14 15:13:50 +0000
commit25eca6793cd4ad7af7e23669ed4f47d075ec696d (patch)
tree23c4549fc84d8f2bf75278d029154a73fc80acac /meta/recipes-devtools/automake/automake.inc
parentae49c16816e23fcfdcfb88d2d763e91be78f9dc0 (diff)
downloadopenembedded-core-contrib-25eca6793cd4ad7af7e23669ed4f47d075ec696d.tar.gz
automake: Remove delays in configure scripts using automake
By default automake puts "sleep 1" into the start of configure scripts which adds pointless delays to them. Rather than do this, lets just assume our systems are sane. Since this means our patches touch m4 files, we need to stop automake running autoreconf so we tweak the do_configure to avoid this. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake.inc')
-rw-r--r--meta/recipes-devtools/automake/automake.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index a1debd8d53..4f9b5f7740 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -10,6 +10,9 @@ SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.gz"
inherit autotools texinfo
do_configure() {
+ # We can end up patching macros, which would then mean autoreconf
+ # Cheat by saying everything is up to date.
+ touch ${S}/aclocal.m4 ${S}/Makefile.in ${S}/configure
oe_runconf
}