aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-06-06 16:22:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 10:21:20 +0100
commit84052c30c7e4b845543c9704945170a55734343e (patch)
treea655e0090a5c88bbf34eeb250b9d51aced4d5c33 /meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
parent6167e415e63366c606c8366abda7edfa21d68b58 (diff)
downloadopenembedded-core-contrib-84052c30c7e4b845543c9704945170a55734343e.tar.gz
autogen-native: upgrade from 2.18.2 to 2.18.3
Upgrade autogen-native from 2.18.2 to 2.18.3. A patch is made to fix the compilation error. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.3.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
new file mode 100644
index 0000000000..61bd21fc38
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Automated text and program generation tool"
+DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
+ maintenance of programs that contain large amounts of repetitious text.\
+ It is especially valuable in programs that have several blocks of text\
+ that must be kept synchronized."
+HOMEPAGE = "http://www.gnu.org/software/autogen/"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
+ file://guile.patch \
+ file://increase-timeout-limit.patch \
+ file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch"
+
+SRC_URI[md5sum] = "0fb6b003423e004d94e0119c2390078f"
+SRC_URI[sha256sum] = "73d05a689105eb9b8be54f32498c99ddbd360776fc61cf45be6a2a4eb4a40039"
+
+DEPENDS = "guile-native libtool-native libxml2-native"
+
+inherit autotools texinfo native
+
+# autogen-native links against libguile which may have been relocated with sstate
+# these environment variables ensure there isn't a relocation issue
+export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
+export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
+
+do_install_append () {
+ create_wrapper ${D}/${bindir}/autogen \
+ GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
+ GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
+}