summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-04-22 00:40:22 +0200
committerAndreas Oberritter <obi@opendreambox.org>2020-07-02 12:17:24 +0200
commit9c6ffd3ba7fbf2de22246b59460d2a4767877659 (patch)
tree52bccdbef10a6ced323ac3923340f0e0b82b25ee /meta/recipes-devtools/apt
parent3a462ba0472f807cbcfca7230730ef1298d22fbb (diff)
downloadopenembedded-core-contrib-9c6ffd3ba7fbf2de22246b59460d2a4767877659.tar.gz
apt-native: merge apt-native.inc into .bb
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-devtools/apt')
-rw-r--r--meta/recipes-devtools/apt/apt-native.inc74
-rw-r--r--meta/recipes-devtools/apt/apt-native_1.2.31.bb75
2 files changed, 73 insertions, 76 deletions
diff --git a/meta/recipes-devtools/apt/apt-native.inc b/meta/recipes-devtools/apt/apt-native.inc
deleted file mode 100644
index d826786329..0000000000
--- a/meta/recipes-devtools/apt/apt-native.inc
+++ /dev/null
@@ -1,74 +0,0 @@
-require apt.inc
-inherit native
-
-DEPENDS += "dpkg-native gettext-native db-native curl-native xz-native"
-PACKAGES = ""
-USE_NLS = "yes"
-
-SRC_URI += "file://db_linking_hack.patch \
- file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
-"
-
-python do_install () {
- bb.build.exec_func('do_install_base', d)
- bb.build.exec_func('do_install_config', d)
-}
-
-python do_install_config () {
- indir = os.path.dirname(d.getVar('FILE'))
- infile = open(oe.path.join(indir, 'files', 'apt.conf'), 'r')
- data = infile.read()
- infile.close()
-
- data = d.expand(data)
-
- outdir = oe.path.join(d.getVar('D'), d.getVar('sysconfdir'), 'apt')
- if not os.path.exists(outdir):
- os.makedirs(outdir)
-
- outpath = oe.path.join(outdir, 'apt.conf.sample')
- if not os.path.exists(outpath):
- outfile = open(outpath, 'w')
- outfile.write(data)
- outfile.close()
-}
-
-do_install_base () {
- install -d ${D}${bindir}
- install -m 0755 bin/apt-cdrom ${D}${bindir}/
- install -m 0755 bin/apt-get ${D}${bindir}/
- install -m 0755 bin/apt-config ${D}${bindir}/
- install -m 0755 bin/apt-cache ${D}${bindir}/
- install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
- install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
- install -m 0755 bin/apt-ftparchive ${D}${bindir}/
-
- oe_libinstall -so -C bin libapt-private ${D}${libdir}/
-
- oe_libinstall -so -C bin libapt-pkg$GLIBC_VER$LIBSTDCPP_VER ${D}${libdir}/
- oe_libinstall -so -C bin libapt-inst$GLIBC_VER$LIBSTDCPP_VER ${D}${libdir}/
-
- install -d ${D}${libdir}/apt/methods
- install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
-
- install -d ${D}${libdir}/dpkg/methods/apt
- install -m 0644 ${S}/dselect/desc.apt ${D}${libdir}/dpkg/methods/apt/
- install -m 0644 ${S}/dselect/names ${D}${libdir}/dpkg/methods/apt/
- install -m 0755 ${S}/dselect/install ${D}${libdir}/dpkg/methods/apt/
- install -m 0755 ${S}/dselect/setup ${D}${libdir}/dpkg/methods/apt/
- install -m 0755 ${S}/dselect/update ${D}${libdir}/dpkg/methods/apt/
-
- install -d ${D}${sysconfdir}/apt
- install -d ${D}${sysconfdir}/apt/apt.conf.d
- install -d ${D}${sysconfdir}/apt/preferences.d
- install -d ${D}${localstatedir}/lib/apt/lists/partial
- install -d ${D}${localstatedir}/cache/apt/archives/partial
-
- install -d ${D}${localstatedir}/log/apt/
-
- install -d ${D}${includedir}/apt-pkg
- for h in `find ${S}/apt-pkg ${S}/apt-inst -name '*.h'`
- do
- install -m 0644 $h ${D}${includedir}/apt-pkg
- done
-}
diff --git a/meta/recipes-devtools/apt/apt-native_1.2.31.bb b/meta/recipes-devtools/apt/apt-native_1.2.31.bb
index 5b16b503d5..4680bd5779 100644
--- a/meta/recipes-devtools/apt/apt-native_1.2.31.bb
+++ b/meta/recipes-devtools/apt/apt-native_1.2.31.bb
@@ -1,7 +1,78 @@
-require apt-native.inc
+require apt.inc
+inherit native
-SRC_URI += "file://noconfigure.patch \
+DEPENDS += "dpkg-native gettext-native db-native curl-native xz-native"
+PACKAGES = ""
+USE_NLS = "yes"
+
+SRC_URI += "file://db_linking_hack.patch \
+ file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
+ file://noconfigure.patch \
file://no-curl.patch \
file://gcc_4.x_apt-pkg-contrib-strutl.cc-Include-array-header.patch \
file://gcc_4.x_Revert-avoid-changing-the-global-LC_TIME-for-Release.patch \
file://gcc_4.x_Revert-use-de-localed-std-put_time-instead-rolling-o.patch"
+
+python do_install () {
+ bb.build.exec_func('do_install_base', d)
+ bb.build.exec_func('do_install_config', d)
+}
+
+python do_install_config () {
+ indir = os.path.dirname(d.getVar('FILE'))
+ infile = open(oe.path.join(indir, 'files', 'apt.conf'), 'r')
+ data = infile.read()
+ infile.close()
+
+ data = d.expand(data)
+
+ outdir = oe.path.join(d.getVar('D'), d.getVar('sysconfdir'), 'apt')
+ if not os.path.exists(outdir):
+ os.makedirs(outdir)
+
+ outpath = oe.path.join(outdir, 'apt.conf.sample')
+ if not os.path.exists(outpath):
+ outfile = open(outpath, 'w')
+ outfile.write(data)
+ outfile.close()
+}
+
+do_install_base () {
+ install -d ${D}${bindir}
+ install -m 0755 bin/apt-cdrom ${D}${bindir}/
+ install -m 0755 bin/apt-get ${D}${bindir}/
+ install -m 0755 bin/apt-config ${D}${bindir}/
+ install -m 0755 bin/apt-cache ${D}${bindir}/
+ install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
+ install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
+ install -m 0755 bin/apt-ftparchive ${D}${bindir}/
+
+ oe_libinstall -so -C bin libapt-private ${D}${libdir}/
+
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER$LIBSTDCPP_VER ${D}${libdir}/
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER$LIBSTDCPP_VER ${D}${libdir}/
+
+ install -d ${D}${libdir}/apt/methods
+ install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
+
+ install -d ${D}${libdir}/dpkg/methods/apt
+ install -m 0644 ${S}/dselect/desc.apt ${D}${libdir}/dpkg/methods/apt/
+ install -m 0644 ${S}/dselect/names ${D}${libdir}/dpkg/methods/apt/
+ install -m 0755 ${S}/dselect/install ${D}${libdir}/dpkg/methods/apt/
+ install -m 0755 ${S}/dselect/setup ${D}${libdir}/dpkg/methods/apt/
+ install -m 0755 ${S}/dselect/update ${D}${libdir}/dpkg/methods/apt/
+
+ install -d ${D}${sysconfdir}/apt
+ install -d ${D}${sysconfdir}/apt/apt.conf.d
+ install -d ${D}${sysconfdir}/apt/preferences.d
+ install -d ${D}${localstatedir}/lib/apt/lists/partial
+ install -d ${D}${localstatedir}/cache/apt/archives/partial
+
+ install -d ${D}${localstatedir}/log/apt/
+
+ install -d ${D}${includedir}/apt-pkg
+ for h in `find ${S}/apt-pkg ${S}/apt-inst -name '*.h'`
+ do
+ install -m 0644 $h ${D}${includedir}/apt-pkg
+ done
+}