summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.2.31.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-04-22 01:55:22 +0200
committerAndreas Oberritter <obi@opendreambox.org>2020-07-02 12:17:24 +0200
commit0c9016a511577771ae66b12496efc1c222a273c9 (patch)
tree4035053f5b8bb3432a28fcfe73771d87adbcc0a3 /meta/recipes-devtools/apt/apt_1.2.31.bb
parentc5ce2079503f5d6f5b6f8b583578a0ec489f9cfe (diff)
downloadopenembedded-core-contrib-0c9016a511577771ae66b12496efc1c222a273c9.tar.gz
apt: merge with apt-native
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.2.31.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.31.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.31.bb b/meta/recipes-devtools/apt/apt_1.2.31.bb
index 898b83e61e..306e836fbd 100644
--- a/meta/recipes-devtools/apt/apt_1.2.31.bb
+++ b/meta/recipes-devtools/apt/apt_1.2.31.bb
@@ -2,6 +2,8 @@ DEPENDS = "curl db zlib"
RDEPENDS_${PN} = "dpkg bash debianutils"
require apt.inc
+USE_NLS_class-native = "yes"
+
PACKAGES =+ "${PN}-utils"
FILES_${PN} += "${libdir}/dpkg ${systemd_system_unitdir}/apt-daily.service"
RDEPENDS_${PN} += "perl"
@@ -74,7 +76,16 @@ PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_
PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
PACKAGECONFIG[lz4] = "ac_cv_lib_lz4_LZ4F_createCompressionContext=yes,ac_cv_lib_lz4_LZ4F_createCompressionContext=no,lz4"
+do_install_append_class-native() {
+ sed -e "s,@STAGING_DIR_NATIVE@,${STAGING_DIR_NATIVE},g" \
+ -e "s,@STAGING_BINDIR_NATIVE@,${STAGING_BINDIR_NATIVE},g" \
+ -e "s,@STAGING_LIBDIR@,${STAGING_LIBDIR},g" \
+ < ${WORKDIR}/apt.conf.in > ${D}${sysconfdir}/apt/apt.conf.sample
+}
+
do_install_append_class-target() {
#Write the correct apt-architecture to apt.conf
echo 'APT::Architecture "${DPKG_ARCH}";' > ${D}${sysconfdir}/apt/apt.conf
}
+
+BBCLASSEXTEND = "native"