aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_0.9.8.2.bb
diff options
context:
space:
mode:
authorIonut Radu <ionutx.radu@intel.com>2013-06-27 13:07:13 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:57:46 -0700
commit1500b4e7f6adec612efbdebad6a08a1efeeda7b6 (patch)
tree516c41ac77a0e5eb24cf04264df55a17244fb0bf /meta/recipes-devtools/apt/apt_0.9.8.2.bb
parent74a803358eb95fda982bc5a2dcdee7461cc971be (diff)
downloadopenembedded-core-contrib-1500b4e7f6adec612efbdebad6a08a1efeeda7b6.tar.gz
apt: Updated from 0.9.8.1 to 0.9.8.2
Signed-off-by: Ionut Radu <ionutx.radu@intel.com> [sgw - fixed apt-native checksums] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_0.9.8.2.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_0.9.8.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_0.9.8.2.bb b/meta/recipes-devtools/apt/apt_0.9.8.2.bb
new file mode 100644
index 0000000000..12952a9b8b
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_0.9.8.2.bb
@@ -0,0 +1,18 @@
+DEPENDS = "curl db"
+RDEPENDS_${PN} = "dpkg"
+LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
+require apt.inc
+
+SRC_URI[md5sum] = "956bb906224a5662111d353ab11a0347"
+SRC_URI[sha256sum] = "cb0360e218490d875dc1e9e15c4e0ba0b53c7f512a6c98253f2eb07877be5106"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_install_append() {
+ #Write the correct apt-architecture to apt.conf
+ APT_CONF=${D}/etc/apt/apt.conf
+ echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
+}