aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorChen Qi <qi.chen@windriver.com>2013-11-02 13:22:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:24:52 +0000
commitf6a9df6b7cd411b52e71022b8f7bf8bda6395649 (patch)
tree56032f1641723d0d035402715027d3fe832d0c8f /meta/recipes-core
parent6059be3ab60b8ab463d438c47bb17553d184a790 (diff)
downloadopenembedded-core-contrib-f6a9df6b7cd411b52e71022b8f7bf8bda6395649.tar.gz
sysvinit: adjust boot sequence and remove hack from udev
Adjust the boot sequence in sysvinit based systems. The mountall.sh (mounting the local file system) needs to be started before udev and bootlogd. This patch makes mountall.sh start before udev and removes the hack of mounting tmpfs in the udev init script. This patch also adds some comments to the udev init script to make it clear why we create the '/var/volatile/tmp' directory. [YOCTO #5273] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/initscripts/initscripts_1.0.bb2
-rw-r--r--meta/recipes-core/udev/udev.inc2
-rw-r--r--meta/recipes-core/udev/udev/init4
3 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-core/initscripts/initscripts_1.0.bb b/meta/recipes-core/initscripts/initscripts_1.0.bb
index c2998c3a02..2d582660fa 100644
--- a/meta/recipes-core/initscripts/initscripts_1.0.bb
+++ b/meta/recipes-core/initscripts/initscripts_1.0.bb
@@ -115,7 +115,7 @@ do_install () {
update-rc.d -r ${D} save-rtc.sh start 25 0 6 .
update-rc.d -r ${D} banner.sh start 02 S .
update-rc.d -r ${D} checkroot.sh start 06 S .
- update-rc.d -r ${D} mountall.sh start 35 S .
+ update-rc.d -r ${D} mountall.sh start 03 S .
update-rc.d -r ${D} hostname.sh start 39 S .
update-rc.d -r ${D} mountnfs.sh start 45 S .
update-rc.d -r ${D} bootmisc.sh start 55 S .
diff --git a/meta/recipes-core/udev/udev.inc b/meta/recipes-core/udev/udev.inc
index 2ff8f006da..02cab3b0d6 100644
--- a/meta/recipes-core/udev/udev.inc
+++ b/meta/recipes-core/udev/udev.inc
@@ -50,7 +50,7 @@ PACKAGES =+ "libgudev libgudev-dev libgudev-dbg"
INITSCRIPT_PACKAGES = "udev udev-cache"
INITSCRIPT_NAME_udev = "udev"
-INITSCRIPT_PARAMS_udev = "start 03 S ."
+INITSCRIPT_PARAMS_udev = "start 04 S ."
INITSCRIPT_NAME_udev-cache = "udev-cache"
INITSCRIPT_PARAMS_udev-cache = "start 36 S ."
diff --git a/meta/recipes-core/udev/udev/init b/meta/recipes-core/udev/udev/init
index e048a171da..410a650bd1 100644
--- a/meta/recipes-core/udev/udev/init
+++ b/meta/recipes-core/udev/udev/init
@@ -54,7 +54,9 @@ case "$1" in
}
[ -e /dev/pts ] || mkdir -m 0755 /dev/pts
[ -e /dev/shm ] || mkdir -m 1777 /dev/shm
- mount -a -t tmpfs 2>/dev/null
+ # the automount rule for udev needs /tmp directory available, as /tmp is a symlink
+ # to /var/tmp which in turn is a symlink to /var/volatile/tmp, we need to make sure
+ # /var/volatile/tmp directory to be available.
mkdir -p /var/volatile/tmp
# Cache handling.