aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-01-23 20:12:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:21:55 +0000
commitf9f193219bd510160b6b09bae652a9dc8ea01e7b (patch)
treed0c7e3fb331177209408c231b407d1b13a74e066 /meta/recipes-core
parent425a3fb935f40325baeff88d2519b601a87c418d (diff)
downloadopenembedded-core-contrib-f9f193219bd510160b6b09bae652a9dc8ea01e7b.tar.gz
Revert "Add missing RDEPENDS of initscripts-functions"
Instead of manually adding initscripts to RDEPENDS of each package, we should make it automatically handled by the update-rc.d.bbclass. This solution would have the benefit of backward compatibility. In other words, users need not modify their recipes. This reverts commit 16080a3485bd793edd66ed8361f1e8b86a9e19ea. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/dbus/dbus.inc2
-rw-r--r--meta/recipes-core/systemd/systemd_208.bb2
-rw-r--r--meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/dbus/dbus.inc b/meta/recipes-core/dbus/dbus.inc
index 86d6caa46c..cf17b62234 100644
--- a/meta/recipes-core/dbus/dbus.inc
+++ b/meta/recipes-core/dbus/dbus.inc
@@ -6,7 +6,7 @@ LICENSE = "AFL-2 | GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
DEPENDS = "expat virtual/libintl"
-RDEPENDS_dbus = "${@base_contains('DISTRO_FEATURES', 'ptest', 'dbus-ptest-ptest', '', d)} initscripts-functions"
+RDEPENDS_dbus = "${@base_contains('DISTRO_FEATURES', 'ptest', 'dbus-ptest-ptest', '', d)}"
RDEPENDS_dbus_class-native = ""
RDEPENDS_dbus_class-nativesdk = ""
diff --git a/meta/recipes-core/systemd/systemd_208.bb b/meta/recipes-core/systemd/systemd_208.bb
index 4b0fa2d4b7..41a106a7c2 100644
--- a/meta/recipes-core/systemd/systemd_208.bb
+++ b/meta/recipes-core/systemd/systemd_208.bb
@@ -237,7 +237,7 @@ PACKAGES =+ "udev-dbg udev udev-utils udev-hwdb"
FILES_udev-dbg += "/lib/udev/.debug"
-RDEPENDS_udev += "udev-utils initscripts-functions"
+RDEPENDS_udev += "udev-utils"
RPROVIDES_udev = "hotplug"
RRECOMMENDS_udev += "udev-hwdb"
diff --git a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
index a84448aadb..dd25f71530 100644
--- a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
PR = "r11"
-RDEPENDS_${PN} = "${PN}-inittab initscripts-functions"
+RDEPENDS_${PN} = "${PN}-inittab"
SRC_URI = "http://download.savannah.gnu.org/releases-noredirect/sysvinit/sysvinit-${PV}.tar.bz2 \
file://install.patch \