aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-10-15 23:59:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-24 12:47:27 +0100
commitf1f9d08ea8b32b0a51a1e3f7bcf488ba7e9dc21e (patch)
treea3646b7949efdd660a19af30fed32401fda0b343 /meta/recipes-core
parentec4553832251615cee65e01e3fd261f5c7863b2e (diff)
downloadopenembedded-core-contrib-f1f9d08ea8b32b0a51a1e3f7bcf488ba7e9dc21e.tar.gz
packagegroup-core-tools-profile: replace 'legacy' lttng with lttng 2.0
packagegroup-core-tools-profile currently pulls in the 'legacy' lttng packages, which are useless without legacy lttng support in the kernel. This makes packagegroup-core-tools-profile pull in the lttng 2.0 packages instead, which don't need any kernel modifications to work. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb25
1 files changed, 21 insertions, 4 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
index c2cd7aca4e..369a64641a 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -5,7 +5,7 @@
SUMMARY = "Profiling tools"
LICENSE = "MIT"
-PR = "r1"
+PR = "r2"
inherit packagegroup
@@ -29,8 +29,7 @@ PROFILETOOLS = "\
oprofileui-server \
powertop \
latencytop \
- lttng-control \
- lttng-viewer"
+ "
# systemtap needs elfutils which is not fully buildable on uclibc
# hence we exclude it from uclibc based builds
@@ -45,11 +44,26 @@ SYSTEMTAP_aarch64 = ""
# which means we can not use syscall() to call it. So we ignore
# it for x86_64/uclibc
-LTTNGUST = "lttng-ust"
+LTTNGUST = "lttng2-ust"
LTTNGUST_libc-uclibc = ""
LTTNGUST_mips = ""
LTTNGUST_aarch64 = ""
+# lttng-tools, lttng-modules and babeltrace all depend on liburcu
+# which currentl doesn't build on mips
+
+LTTNGTOOLS = "lttng-tools"
+LTTNGTOOLS_mips = ""
+LTTNGTOOLS_aarch64 = ""
+
+LTTNGMODULES = "lttng-modules"
+LTTNGMODULES_mips = ""
+LTTNGMODULES_aarch64 = ""
+
+BABELTRACE = "babeltrace"
+BABELTRACE_mips = ""
+BABELTRACE_aarch64 = ""
+
# valgrind does not work on mips
VALGRIND = "valgrind"
@@ -68,6 +82,9 @@ VALGRIND_aarch64 = ""
RDEPENDS_${PN} = "\
${PROFILETOOLS} \
${LTTNGUST} \
+ ${LTTNGTOOLS} \
+ ${LTTNGMODULES} \
+ ${BABELTRACE} \
${SYSTEMTAP} \
${VALGRIND} \
"