aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-04-03 08:13:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-03 14:07:55 +0100
commite165203a6a7eb1fd47a20c3ede4d5a20ad49487f (patch)
treeacaa4f8764576ba3b4df80cb3e8e75491f8a2ef6 /meta/recipes-core
parent5bcb68a232539cf11a30e3b812b2fbd6d7d76e35 (diff)
downloadopenembedded-core-contrib-e165203a6a7eb1fd47a20c3ede4d5a20ad49487f.tar.gz
eglibc: SDK_GLIBC_ADDONS for eglibc-nativesdk.
Use SDK_GLIBC_ADDONS for eglibc-nativesdk so that it is not dependant on the target eglibc's GLIBC_ADDONS settings. Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc4
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb5
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb4
3 files changed, 7 insertions, 6 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index da5c1872ea..8e3fe503b8 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -50,3 +50,7 @@ do_configure_prepend() {
sed -e "s#@BASH@#/bin/sh#" -i ${S}/elf/ldd.bash.in
echo '${OE_FEATURES}' > ${B}/option-groups.config
}
+
+GLIBC_ADDONS ?= "ports,nptl,libidn"
+SDK_GLIBC_ADDONS ?= "ports,nptl,libidn"
+GLIBC_ADDONS_virtclass-nativesdk = "${SDK_GLIBC_ADDONS}"
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index e02c80fe44..927f72faac 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "15508"
DEPENDS += "gperf-native"
-PR = "r22"
+PR = "r23"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"
@@ -36,8 +36,6 @@ PROVIDES_${PN}-dbg = "glibc-dbg"
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
-GLIBC_ADDONS ?= "ports,nptl,libidn"
-
GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
@@ -60,6 +58,7 @@ python __anonymous () {
export libc_cv_slibdir = "${base_libdir}"
+
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index 75ccace76b..1575e7fa75 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "17386"
DEPENDS += "gperf-native"
-PR = "r2"
+PR = "r3"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_15"
@@ -41,8 +41,6 @@ PROVIDES_${PN}-dbg = "glibc-dbg"
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
-GLIBC_ADDONS ?= "ports,nptl,libidn"
-
GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"