aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-20 10:24:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-22 16:26:35 +0100
commitc075634135249d3d5d84bbb6dd98e98d3fbf938c (patch)
treef447fdc85cdfa45db1d1caca3befc36b888fab33 /meta/recipes-core
parent6e272b2013d08803e8a4bc33d794a8a58c5c3e4f (diff)
downloadopenembedded-core-contrib-c075634135249d3d5d84bbb6dd98e98d3fbf938c.tar.gz
glib-2.0 2.28.x: update to 2.28.8
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch28
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch25
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.28.8.bb (renamed from meta/recipes-core/glib-2.0/glib-2.0_2.28.6.bb)12
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc3
4 files changed, 63 insertions, 5 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch b/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
new file mode 100644
index 0000000000..ad1ca12b80
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
@@ -0,0 +1,28 @@
+From 3d371334d5668bcd02a38ff99884bd343c244d68 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sat, 18 Jun 2011 23:51:35 +0200
+Subject: [PATCH 3/7] gatomic-proper-pointer-get-cast.patch
+
+Upstream-Status: Unknown
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ glib/gatomic.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/glib/gatomic.h b/glib/gatomic.h
+index ddd39b8..b758142 100644
+--- a/glib/gatomic.h
++++ b/glib/gatomic.h
+@@ -70,7 +70,7 @@ void g_atomic_pointer_set (volatile gpointer G_GNUC_MAY_ALI
+ (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
+ # define g_atomic_pointer_get(atomic) \
+ ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
+- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
++ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void G_GNUC_MAY_ALIAS *) (atomic)))
+ # define g_atomic_pointer_set(atomic, newval) \
+ ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
+ (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
+--
+1.6.6.1
+
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch b/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
new file mode 100644
index 0000000000..678033039f
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
@@ -0,0 +1,25 @@
+From a8e5c4a808e7f8572bd5023645a6cb4386b9aff8 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sat, 18 Jun 2011 23:52:17 +0200
+Subject: [PATCH 5/7] don't leak buildpaths into perl hashbang
+
+Upstream-Status: Unknown
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ gobject/glib-mkenums.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/gobject/glib-mkenums.in b/gobject/glib-mkenums.in
+index 6372245..b486fe9 100755
+--- a/gobject/glib-mkenums.in
++++ b/gobject/glib-mkenums.in
+@@ -1,4 +1,4 @@
+-#! @PERL_PATH@
++#! /usr/bin/env perl
+
+ use warnings;
+ use File::Basename;
+--
+1.6.6.1
+
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.28.6.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.28.8.bb
index ca5f4c8b1c..e84aea5344 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.28.6.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.28.8.bb
@@ -1,18 +1,22 @@
require glib.inc
-PE = "1"
PR = "r1"
+PE = "1"
SRC_URI = "${GNOME_MIRROR}/glib/2.28/glib-${PV}.tar.bz2 \
file://configure-libtool.patch \
file://60_wait-longer-for-threads-to-die.patch \
file://g_once_init_enter.patch \
+ file://0003-gatomic-proper-pointer-get-cast.patch.patch \
+ file://0005-glib-mkenums-interpreter.patch.patch \
"
# Only apply this patch for target recipe on uclibc
SRC_URI_append_libc-uclibc = " ${@['', 'file://no-iconv.patch']['${PN}' == '${BPN}']}"
-SRC_URI[md5sum] = "7d8fc15ae70d5111c0cf2a79d50ef717"
-SRC_URI[sha256sum] = "557fb7c39d21b9359fbac51fd6b0b883bc97a2561c0166eef993a4078312f578"
-
SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
+
+SRC_URI[md5sum] = "789e7520f71c6a4bf08bc683ec764d24"
+SRC_URI[sha256sum] = "222f3055d6c413417b50901008c654865e5a311c73f0ae918b0a9978d1f9466f"
+
BBCLASSEXTEND = "native"
+
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 0488490b86..0800c85c4a 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -31,7 +31,8 @@ EXTRA_OECONF = "--disable-debug --enable-included-printf=no"
EXTRA_OECONF_virtclass-native = ""
EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no"
-FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN} = "${libdir}/lib*${SOLIBS} ${sysconfdir}/bash_completion.d ${datadir}/glib-2.0/schemas"
FILES_${PN}-dev += "${libdir}/glib-2.0/include"
+FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb"
ARM_INSTRUCTION_SET = "arm"