aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2011-01-21 17:27:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-25 12:25:46 +0000
commitb0df35f47fb79dc149504bd66d1186b3276f9510 (patch)
treea90ab5811d677fc6dc920a6cb158d91746f931ed /meta/recipes-core
parent562789455df668e20e87b008ea4a080ee42bd9f4 (diff)
downloadopenembedded-core-contrib-b0df35f47fb79dc149504bd66d1186b3276f9510.tar.gz
base-files: Add to make some directories needed by LSB.
LSB will check some directories,eg, "/usr/local/" and need to make them for LSB test. Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 055769695e..2363feb6ba 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -2,7 +2,7 @@ SUMMARY = "Miscellaneous files for the base system."
DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system."
SECTION = "base"
PRIORITY = "required"
-PR = "r65"
+PR = "r66"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f"
SRC_URI = "file://rotation \
@@ -48,6 +48,12 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
/mnt /media /media/card /media/cf /media/net /media/ram \
/media/union /media/realroot /media/hdd \
/media/mmc1"
+dirs3755 = "/srv \
+ ${prefix}/local ${prefix}/local/bin ${prefix}/local/games \
+ ${prefix}/local/include ${prefix}/local/lib ${prefix}/local/sbin \
+ ${prefix}/local/share ${prefix}/local/src"
+dirs4775 = "/var/mail"
+
volatiles = "cache run log lock tmp"
conffiles = "${sysconfdir}/debian_version ${sysconfdir}/host.conf \
${sysconfdir}/inputrc ${sysconfdir}/issue /${sysconfdir}/issue.net \
@@ -156,6 +162,16 @@ do_install_append_netbook-pro () {
mkdir -p ${D}/initrd
}
+do_install_append_poky-lsb() {
+ for d in ${dirs3755}; do
+ install -m 0755 -d ${D}$d
+ done
+
+ for d in ${dirs4775}; do
+ install -m 2755 -d ${D}$d
+ done
+}
+
PACKAGES = "${PN}-doc ${PN} ${PN}-dev ${PN}-dbg"
FILES_${PN} = "/"
FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"