aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-31 10:21:04 -0700
commit81813c0e322dc04ce4b069117188d8a54dfddb8c (patch)
tree3363bac6dcdcdad14ba58efcea39529436cdf72d /meta/recipes-core
parentf01f0b8aed25af889f48fe1afff96feb3d9ed120 (diff)
downloadopenembedded-core-contrib-81813c0e322dc04ce4b069117188d8a54dfddb8c.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/dbus/dbus.inc2
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale.inc15
-rw-r--r--meta/recipes-core/eglibc/eglibc-package.inc53
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb2
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc2
-rw-r--r--meta/recipes-core/meta/external-python-tarball.bb38
-rw-r--r--meta/recipes-core/tasks/nativesdk-task-sdk-host.bb (renamed from meta/recipes-core/tasks/task-sdk-host-nativesdk.bb)24
7 files changed, 65 insertions, 71 deletions
diff --git a/meta/recipes-core/dbus/dbus.inc b/meta/recipes-core/dbus/dbus.inc
index 1984c74c6d..8f35f56d1b 100644
--- a/meta/recipes-core/dbus/dbus.inc
+++ b/meta/recipes-core/dbus/dbus.inc
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
X11DEPENDS = "virtual/libx11 libsm"
DEPENDS = "expat virtual/libintl ${@base_contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
DEPENDS_virtclass-native = "expat-native virtual/libintl-native"
-DEPENDS_virtclass-nativesdk = "expat-nativesdk virtual/libintl-nativesdk virtual/libx11"
+DEPENDS_virtclass-nativesdk = "nativesdk-expat virtual/nativesdk-libintl virtual/libx11"
INC_PR = "r3"
diff --git a/meta/recipes-core/eglibc/eglibc-locale.inc b/meta/recipes-core/eglibc/eglibc-locale.inc
index d6bdcb5f2e..296afdef6e 100644
--- a/meta/recipes-core/eglibc/eglibc-locale.inc
+++ b/meta/recipes-core/eglibc/eglibc-locale.inc
@@ -17,7 +17,7 @@ do_compile[noexec] = "1"
# default to disabled
ENABLE_BINARY_LOCALE_GENERATION ?= "0"
-ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
+ENABLE_BINARY_LOCALE_GENERATION_pn-nativesdk-eglibc-locale = "0"
#enable locale generation on these arches
# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
@@ -29,16 +29,13 @@ LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
PR = "r22"
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+PROVIDES = "virtual/libc-locale"
-PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
-
-PACKAGES = "localedef${PKGSUFFIX} ${PN}-dbg"
+PACKAGES = "localedef ${PN}-dbg"
PACKAGES_DYNAMIC = "locale-base-* \
eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
- glibc-gconv-*${PKGSUFFIX} glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
+ glibc-gconv-* glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
# Create a eglibc-binaries package
ALLOW_EMPTY_${BPN}-binaries = "1"
@@ -67,7 +64,7 @@ DESCRIPTION_localedef = "eglibc: compile locale definition files"
# Explicitly add ${MLPREFIX} for FILES_eglibc-gconv.
FILES_${MLPREFIX}eglibc-gconv = "${libdir}/gconv/*"
FILES_${PN}-dbg += "${libdir}/gconv/.debug/*"
-FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
+FILES_localedef = "${bindir}/localedef"
LOCALETREESRC = "${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}"
@@ -93,6 +90,6 @@ do_install () {
inherit libc-package
-do_install[depends] += "virtual/${MLPREFIX}libc${PKGSUFFIX}:do_populate_sysroot"
+do_install[depends] += "virtual/${MLPREFIX}libc:do_populate_sysroot"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/eglibc/eglibc-package.inc b/meta/recipes-core/eglibc/eglibc-package.inc
index af784565d4..bd46cb8561 100644
--- a/meta/recipes-core/eglibc/eglibc-package.inc
+++ b/meta/recipes-core/eglibc/eglibc-package.inc
@@ -17,47 +17,44 @@ python __anonymous () {
# Set this to zero if you don't want ldconfig in the output package
USE_LDCONFIG ?= "1"
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
-
-PACKAGES = "${PN}-dbg catchsegv${PKGSUFFIX} sln${PKGSUFFIX} nscd${PKGSUFFIX} ldd${PKGSUFFIX} ${PN}-mtrace ${PN}-utils eglibc-thread-db${PKGSUFFIX} ${PN}-pic libcidn${PKGSUFFIX} libmemusage${PKGSUFFIX} libsegfault${PKGSUFFIX} ${PN}-pcprofile libsotruss${PKGSUFFIX} ${PN}-dev ${PN}-staticdev ${PN}-doc ${PN} eglibc-extra-nss${PKGSUFFIX}"
+PACKAGES = "${PN}-dbg catchsegv sln nscd ldd ${PN}-mtrace ${PN}-utils eglibc-thread-db ${PN}-pic libcidn libmemusage libsegfault ${PN}-pcprofile libsotruss ${PN}-dev ${PN}-staticdev ${PN}-doc ${PN} eglibc-extra-nss"
# The ld.so in this eglibc supports the GNU_HASH
-RPROVIDES_${PN} = "glibc${PKGSUFFIX} rtld(GNU_HASH)"
-RPROVIDES_${PN}-utils = "glibc${PKGSUFFIX}-utils"
-RPROVIDES_${PN}-mtrace = "glibc${PKGSUFFIX}-mtrace libc-mtrace"
-RPROVIDES_${PN}-pic = "glibc${PKGSUFFIX}-pic"
-RPROVIDES_${PN}-dev = "glibc${PKGSUFFIX}-dev"
-RPROVIDES_${PN}-staticdev = "glibc${PKGSUFFIX}-staticdev"
-RPROVIDES_${PN}-doc = "glibc${PKGSUFFIX}-doc"
-RPROVIDES_eglibc-extra-nss${PKGSUFFIX} = "glibc-extra-nss${PKGSUFFIX}"
-RPROVIDES_eglibc-thread-db${PKGSUFFIX} = "glibc-thread-db${PKGSUFFIX}"
-RPROVIDES_${PN}-pcprofile = "glibc${PKGSUFFIX}-pcprofile"
-RPROVIDES_${PN}-dbg = "glibc-dbg${PKGSUFFIX}"
+RPROVIDES_${PN} = "glibc rtld(GNU_HASH)"
+RPROVIDES_${PN}-utils = "glibc-utils"
+RPROVIDES_${PN}-mtrace = "glibc-mtrace libc-mtrace"
+RPROVIDES_${PN}-pic = "glibc-pic"
+RPROVIDES_${PN}-dev = "glibc-dev"
+RPROVIDES_${PN}-staticdev = "glibc-staticdev"
+RPROVIDES_${PN}-doc = "glibc-doc"
+RPROVIDES_eglibc-extra-nss = "glibc-extra-nss"
+RPROVIDES_eglibc-thread-db = "glibc-thread-db"
+RPROVIDES_${PN}-pcprofile = "glibc-pcprofile"
+RPROVIDES_${PN}-dbg = "glibc-dbg"
libc_baselibs = "${base_libdir}/libcrypt*.so.* ${base_libdir}/libcrypt-*.so ${base_libdir}/libc.so.* ${base_libdir}/libc-*.so ${base_libdir}/libm*.so.* ${base_libdir}/libm-*.so ${base_libdir}/ld*.so.* ${base_libdir}/ld-*.so ${base_libdir}/libpthread*.so.* ${base_libdir}/libpthread-*.so ${base_libdir}/libresolv*.so.* ${base_libdir}/libresolv-*.so ${base_libdir}/librt*.so.* ${base_libdir}/librt-*.so ${base_libdir}/libutil*.so.* ${base_libdir}/libutil-*.so ${base_libdir}/libnsl*.so.* ${base_libdir}/libnsl-*.so ${base_libdir}/libnss_files*.so.* ${base_libdir}/libnss_files-*.so ${base_libdir}/libnss_compat*.so.* ${base_libdir}/libnss_compat-*.so ${base_libdir}/libnss_dns*.so.* ${base_libdir}/libnss_dns-*.so ${base_libdir}/libdl*.so.* ${base_libdir}/libdl-*.so ${base_libdir}/libanl*.so.* ${base_libdir}/libanl-*.so ${base_libdir}/libBrokenLocale*.so.* ${base_libdir}/libBrokenLocale-*.so"
FILES_${PN} = "${libc_baselibs} ${libexecdir}/* ${@base_conditional('USE_LDCONFIG', '1', '${base_sbindir}/ldconfig ${sysconfdir}/ld.so.conf', '', d)}"
-FILES_ldd${PKGSUFFIX} = "${bindir}/ldd"
-FILES_libsegfault${PKGSUFFIX} = "${base_libdir}/libSegFault*"
-FILES_libcidn${PKGSUFFIX} = "${base_libdir}/libcidn-*.so ${base_libdir}/libcidn.so.*"
-FILES_libmemusage${PKGSUFFIX} = "${base_libdir}/libmemusage.so"
-FILES_eglibc-extra-nss${PKGSUFFIX} = "${base_libdir}/libnss_*-*.so ${base_libdir}/libnss_*.so.*"
-FILES_sln${PKGSUFFIX} = "/sbin/sln"
+FILES_ldd = "${bindir}/ldd"
+FILES_libsegfault = "${base_libdir}/libSegFault*"
+FILES_libcidn = "${base_libdir}/libcidn-*.so ${base_libdir}/libcidn.so.*"
+FILES_libmemusage = "${base_libdir}/libmemusage.so"
+FILES_eglibc-extra-nss = "${base_libdir}/libnss_*-*.so ${base_libdir}/libnss_*.so.*"
+FILES_sln = "/sbin/sln"
FILES_${PN}-pic = "${libdir}/*_pic.a ${libdir}/*_pic.map ${libdir}/libc_pic/*.o"
-FILES_libsotruss${PKGSUFFIX} = "${libdir}/audit/sotruss-lib.so"
+FILES_libsotruss = "${libdir}/audit/sotruss-lib.so"
FILES_SOLIBSDEV = "${libdir}/lib*${SOLIBSDEV}"
FILES_${PN}-dev += "${bindir}/rpcgen ${libdir}/*_nonshared.a ${base_libdir}/*_nonshared.a ${base_libdir}/*.o ${datadir}/aclocal"
FILES_${PN}-staticdev += "${libdir}/*.a ${base_libdir}/*.a"
-FILES_nscd${PKGSUFFIX} = "${sbindir}/nscd*"
+FILES_nscd = "${sbindir}/nscd*"
FILES_${PN}-mtrace = "${bindir}/mtrace"
FILES_${PN}-utils = "${bindir}/* ${sbindir}/*"
FILES_${PN}-dbg += "${libexecdir}/*/.debug ${libdir}/audit/.debug"
-FILES_catchsegv${PKGSUFFIX} = "${bindir}/catchsegv"
-RDEPENDS_catchsegv${PKGSUFFIX} = "libsegfault"
+FILES_catchsegv = "${bindir}/catchsegv"
+RDEPENDS_catchsegv = "libsegfault"
RDEPENDS_${PN}-utils += "bash"
RDEPENDS_${PN}-mtrace += "perl"
FILES_${PN}-pcprofile = "${base_libdir}/libpcprofile.so"
-FILES_eglibc-thread-db${PKGSUFFIX} = "${base_libdir}/libthread_db.so.* ${base_libdir}/libthread_db-*.so"
+FILES_eglibc-thread-db = "${base_libdir}/libthread_db.so.* ${base_libdir}/libthread_db-*.so"
RPROVIDES_${PN}-dev += "libc-dev"
RPROVIDES_${PN}-staticdev += "libc-staticdev"
@@ -65,8 +62,8 @@ SUMMARY_sln = "The static ln."
DESCRIPTION_sln = "Similar to the 'ln' utility, but statically linked. sln is useful to make symbolic links to dynamic libraries if the dynamic linking system, for some reason, is not functional."
SUMMARY_nscd = "Name service cache daemon"
DESCRIPTION_nscd = "nscd, name service cache daemon, caches name service lookups for the passwd, group and hosts information. It can damatically improvide performance with remote, such as NIS or NIS+, name services."
-SUMMARY_eglibc-extra-nss${PKGSUFFIX} = "hesiod, NIS and NIS+ nss libraries"
-DESCRIPTION_eglibc-extra-nss${PKGSUFFIX} = "eglibc: nis, nisplus and hesiod search services."
+SUMMARY_eglibc-extra-nss = "hesiod, NIS and NIS+ nss libraries"
+DESCRIPTION_eglibc-extra-nss = "eglibc: nis, nisplus and hesiod search services."
SUMMARY_ldd = "print shared library dependencies"
DESCRIPTION_ldd = "/usr/bin/ldd prints shared library dependencies for each program or shared library specified on the command line."
SUMMARY_${PN}-utils = "Miscellaneous utilities provided by eglibc"
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
index 7bc97d68d3..3a075d48e8 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
@@ -5,7 +5,7 @@ PE = "1"
DEPENDS += "libffi python-argparse-native zlib"
DEPENDS_virtclass-native += "libffi-native python-argparse-native"
-DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nativesdk ${BPN}-native"
+DEPENDS_virtclass-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 9dca440e80..8b099f223e 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -15,7 +15,7 @@ SECTION = "libs"
DEPENDS = "glib-2.0-native zip virtual/libiconv"
DEPENDS_virtclass-native = "pkgconfig-native gettext-native"
-DEPENDS_virtclass-nativesdk = "libtool-nativesdk"
+DEPENDS_virtclass-nativesdk = "nativesdk-libtool"
PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"
LEAD_SONAME = "libglib-2.0.*"
diff --git a/meta/recipes-core/meta/external-python-tarball.bb b/meta/recipes-core/meta/external-python-tarball.bb
index e317ba32ca..2085acc223 100644
--- a/meta/recipes-core/meta/external-python-tarball.bb
+++ b/meta/recipes-core/meta/external-python-tarball.bb
@@ -16,25 +16,25 @@ SDK_DEPLOY = "${TMPDIR}/deploy/sdk"
IPKG_HOST = "opkg-cl -f ${IPKGCONF_SDK} -o ${SDK_OUTPUT}"
TOOLCHAIN_HOST_TASK ?= "\
- python-nativesdk-core \
- python-nativesdk-textutils \
- python-nativesdk-sqlite3 \
- python-nativesdk-pickle \
- python-nativesdk-logging \
- python-nativesdk-elementtree \
- python-nativesdk-curses \
- python-nativesdk-compile \
- python-nativesdk-compiler \
- python-nativesdk-fcntl \
- python-nativesdk-shell \
- python-nativesdk-misc \
- python-nativesdk-multiprocessing \
- python-nativesdk-subprocess \
- python-nativesdk-xmlrpc \
- python-nativesdk-netclient \
- python-nativesdk-netserver \
- python-nativesdk-distutils \
- chrpath-nativesdk \
+ nativesdk-python-core \
+ nativesdk-python-textutils \
+ nativesdk-python-sqlite3 \
+ nativesdk-python-pickle \
+ nativesdk-python-logging \
+ nativesdk-python-elementtree \
+ nativesdk-python-curses \
+ nativesdk-python-compile \
+ nativesdk-python-compiler \
+ nativesdk-python-fcntl \
+ nativesdk-python-shell \
+ nativesdk-python-misc \
+ nativesdk-python-multiprocessing \
+ nativesdk-python-subprocess \
+ nativesdk-python-xmlrpc \
+ nativesdk-python-netclient \
+ nativesdk-python-netserver \
+ nativesdk-python-distutils \
+ nativesdk-chrpath \
"
TOOLCHAIN_OUTPUTNAME ?= "python-nativesdk-standalone-${SDKMACHINE}"
diff --git a/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb b/meta/recipes-core/tasks/nativesdk-task-sdk-host.bb
index 920f359eea..ea054bc9c9 100644
--- a/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
+++ b/meta/recipes-core/tasks/nativesdk-task-sdk-host.bb
@@ -15,21 +15,21 @@ inherit nativesdk
PACKAGES = "${PN}"
RDEPENDS_${PN} = "\
- pkgconfig-nativesdk \
- qemu-nativesdk \
- qemu-helper-nativesdk \
- pseudo-nativesdk \
- unfs-server-nativesdk \
- opkg-nativesdk \
- libtool-nativesdk \
- autoconf-nativesdk \
- automake-nativesdk \
+ nativesdk-pkgconfig \
+ nativesdk-qemu \
+ nativesdk-qemu-helper \
+ nativesdk-pseudo \
+ nativesdk-unfs-server \
+ nativesdk-opkg \
+ nativesdk-libtool \
+ nativesdk-autoconf \
+ nativesdk-automake \
"
RDEPENDS_${PN}_darwin8 = "\
odcctools-cross-canadian \
llvm-cross-canadian \
- pkgconfig-nativesdk \
- opkg-nativesdk \
- libtool-nativesdk \
+ nativesdk-pkgconfig \
+ nativesdk-opkg \
+ nativesdk-libtool \
"