aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-10-16 13:27:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-30 17:33:00 +0000
commit7aabc9408fb382f0ae39f9932b6d9ac391528b76 (patch)
tree8af416d931c1d2e6894db4280f7f88262bf31631 /meta/recipes-core
parenta6b02fe439fa13c8482383fba2bfdcb0e9742141 (diff)
downloadopenembedded-core-contrib-7aabc9408fb382f0ae39f9932b6d9ac391528b76.tar.gz
systemd-compat-units: run-postinsts fix script link
in commit fe039170236080291c0220476a5809774f82ee5c Author: Muhammad Shakeel <muhammad_shakeel@mentor.com> Date: Wed Oct 2 10:55:32 2013 +0000 systemd-compat-units: Use correct run-postinsts script link OE-Core commit 75a14923da1ba91eddde47f0907345c19c82d6f0 has moved run-postinsts script execution from S98 to S99 in rcS.d. run-postinsts.service should check for this script and run it on first boot rather than S98run-postinsts, which is for opkg/dpkg. the link was corrected but the mentioned commit is not available. Instead of reverting, we use the same variable as opkg for init script ordering and drop a note in case somebody wants to change default. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb8
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service4
2 files changed, 9 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index c47c14bf95..6eb5ffd985 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -14,6 +14,8 @@ SRC_URI = "file://*.service"
do_install() {
install -d ${D}${systemd_unitdir}/system/basic.target.wants
install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
+ sed -i -e 's,@POSTINSTALL_INITPOSITION@,${POSTINSTALL_INITPOSITION},g' \
+ ${WORKDIR}/run-postinsts.service
install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
@@ -53,4 +55,8 @@ pkg_postinst_${PN} () {
FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
RDPEPENDS_${PN} = "systemd"
-
+# Define a variable to allow distros to run configure earlier.
+# (for example, to enable loading of ethernet kernel modules before networking starts)
+# note: modifying name or default value for POSTINSTALL_INITPOSITION requires
+# changes in opkg.inc
+POSTINSTALL_INITPOSITION ?= "98"
diff --git a/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service b/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service
index 4ebc2344cf..35cf3d32de 100644
--- a/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service
+++ b/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service
@@ -1,12 +1,12 @@
[Unit]
Description=Run pending postinsts
DefaultDependencies=no
-ConditionPathExists=|/etc/rcS.d/S99run-postinsts
+ConditionPathExists=|/etc/rcS.d/S@POSTINSTALL_INITPOSITION@run-postinsts
After=systemd-remount-fs.service systemd-tmpfiles-setup.service tmp.mount
Before=sysinit.target
[Service]
-ExecStart=/etc/rcS.d/S99run-postinsts
+ExecStart=/etc/rcS.d/S@POSTINSTALL_INITPOSITION@run-postinsts
RemainAfterExit=No
Type=oneshot
StandardOutput=syslog