aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-20 14:18:45 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-20 14:18:45 +0100
commit79a4501a2ead92cb512eef0bd3dfe133d0e5d799 (patch)
tree5f82f1971c81034799bd5ab330e54b281020fc24 /meta/recipes-core
parent03d9669cbcc35a49120b9cc277723bccd93f4cf3 (diff)
downloadopenembedded-core-contrib-79a4501a2ead92cb512eef0bd3dfe133d0e5d799.tar.gz
Complete packages -> recipes transition
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb43
-rw-r--r--meta/recipes-core/images/poky-image-core.bb9
-rw-r--r--meta/recipes-core/tasks/task-poky-nfs.bb24
-rw-r--r--meta/recipes-core/tasks/task-poky-sdk.bb84
-rw-r--r--meta/recipes-core/tasks/task-poky-standalone-sdk-target.bb14
-rw-r--r--meta/recipes-core/tasks/task-poky-tools.bb77
-rw-r--r--meta/recipes-core/tasks/task-sdk-host.bb32
7 files changed, 283 insertions, 0 deletions
diff --git a/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb b/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb
new file mode 100644
index 0000000000..f36b38a7e5
--- /dev/null
+++ b/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Poky example feed configuration"
+LICENSE = "MIT"
+
+PR = "r1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#FEEDNAMEPREFIX ?= "INVALID"
+#FEEDURIPREFIX ?= "INVALID"
+
+do_compile() {
+ mkdir -p ${S}/${sysconfdir}/opkg/
+
+ archconf=${S}/${sysconfdir}/opkg/arch.conf
+
+ rm -f $archconf
+ ipkgarchs="${PACKAGE_ARCHS}"
+ priority=1
+ for arch in $ipkgarchs; do
+ echo "arch $arch $priority" >> $archconf
+ priority=$(expr $priority + 5)
+ done
+
+ basefeedconf=${S}/${sysconfdir}/opkg/base-feeds.conf
+
+ rm -f $basefeedconf
+ touch $basefeedconf
+
+ #for arch in $ipkgarchs; do
+ # echo "src/gz ${FEEDNAMEPREFIX}-$arch http://pokylinux.org/${FEEDURIPREFIX}$arch" >> $basefeedconf
+ #done
+}
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
+}
+
+FILES_${PN} = "${sysconfdir}/opkg/ "
+
+CONFFILES_${PN} += "${sysconfdir}/opkg/base-feeds.conf \
+ ${sysconfdir}/opkg/arch.conf"
+
diff --git a/meta/recipes-core/images/poky-image-core.bb b/meta/recipes-core/images/poky-image-core.bb
new file mode 100644
index 0000000000..c232ccdc54
--- /dev/null
+++ b/meta/recipes-core/images/poky-image-core.bb
@@ -0,0 +1,9 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+
+IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
+
+LICENSE = "MIT"
+
+inherit poky-image
diff --git a/meta/recipes-core/tasks/task-poky-nfs.bb b/meta/recipes-core/tasks/task-poky-nfs.bb
new file mode 100644
index 0000000000..b929bbe82a
--- /dev/null
+++ b/meta/recipes-core/tasks/task-poky-nfs.bb
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "NFS tasks for Poky"
+LICENSE = "MIT"
+PR = "r0"
+
+PACKAGES = "\
+ task-poky-nfs-server \
+ task-poky-nfs-server-dbg \
+ task-poky-nfs-server-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-poky-nfs-server = "\
+ nfs-utils"
+
+# rpcinfo can be useful but only with glibc images
+GLIBC_DEPENDENCIES = "glibc-utils"
+
+RRECOMMENDS_task-poky-nfs-server_append_linux = "${GLIBC_DEPENDENCIES}"
+RRECOMMENDS_task-poky-nfs-server_append_linux-gnueabi = "${GLIBC_DEPENDENCIES}" \ No newline at end of file
diff --git a/meta/recipes-core/tasks/task-poky-sdk.bb b/meta/recipes-core/tasks/task-poky-sdk.bb
new file mode 100644
index 0000000000..021878cf06
--- /dev/null
+++ b/meta/recipes-core/tasks/task-poky-sdk.bb
@@ -0,0 +1,84 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+
+DESCRIPTON = "Software Development Tasks for OpenedHand Poky"
+LICENSE = "MIT"
+DEPENDS = "task-poky"
+PR = "r5"
+
+ALLOW_EMPTY = "1"
+#PACKAGEFUNCS =+ 'generate_sdk_pkgs'
+
+PACKAGES = "\
+ task-poky-sdk \
+ task-poky-sdk-dbg \
+ task-poky-sdk-dev"
+
+RDEPENDS_task-poky-sdk = "\
+ autoconf \
+ automake \
+ binutils \
+ binutils-symlinks \
+ coreutils \
+ cpp \
+ cpp-symlinks \
+ diffutils \
+ gcc \
+ gcc-symlinks \
+ g++ \
+ g++-symlinks \
+ gettext \
+ make \
+ intltool \
+ libstdc++ \
+ libstdc++-dev \
+ libtool \
+ perl-module-re \
+ perl-module-text-wrap \
+ pkgconfig \
+ findutils \
+ quilt \
+ less \
+ distcc"
+
+#python generate_sdk_pkgs () {
+# poky_pkgs = read_pkgdata('task-poky', d)['PACKAGES']
+# pkgs = bb.data.getVar('PACKAGES', d, 1).split()
+# for pkg in poky_pkgs.split():
+# newpkg = pkg.replace('task-poky', 'task-poky-sdk')
+#
+# # for each of the task packages, add a corresponding sdk task
+# pkgs.append(newpkg)
+#
+# # for each sdk task, take the rdepends of the non-sdk task, and turn
+# # that into rrecommends upon the -dev versions of those, not unlike
+# # the package depchain code
+# spkgdata = read_subpkgdata(pkg, d)
+#
+# rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '')
+# rreclist = []
+#
+# for depend in rdepends:
+# split_depend = depend.split(' (')
+# name = split_depend[0].strip()
+# if packaged('%s-dev' % name, d):
+# rreclist.append('%s-dev' % name)
+# else:
+# deppkgdata = read_subpkgdata(name, d)
+# rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '')
+# for depend in rdepends2:
+# split_depend = depend.split(' (')
+# name = split_depend[0].strip()
+# if packaged('%s-dev' % name, d):
+# rreclist.append('%s-dev' % name)
+#
+# oldrrec = bb.data.getVar('RRECOMMENDS_%s' % newpkg, d) or ''
+# bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d)
+# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, bb.data.getVar('RRECOMMENDS_%s' % newpkg, d)))
+#
+# # bb.note('pkgs is %s' % pkgs)
+# bb.data.setVar('PACKAGES', ' '.join(pkgs), d)
+#}
+#
+#PACKAGES_DYNAMIC = "task-poky-sdk-*"
diff --git a/meta/recipes-core/tasks/task-poky-standalone-sdk-target.bb b/meta/recipes-core/tasks/task-poky-standalone-sdk-target.bb
new file mode 100644
index 0000000000..4aa318881c
--- /dev/null
+++ b/meta/recipes-core/tasks/task-poky-standalone-sdk-target.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Target packages for the standalone SDK"
+PR = "r6"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PACKAGES = "${PN} ${PN}-dbg"
+
+RDEPENDS_${PN} = "\
+ libgcc \
+ libgcc-dev \
+ libstdc++ \
+ libstdc++-dev \
+ ${LIBC_DEPENDENCIES} \
+ "
diff --git a/meta/recipes-core/tasks/task-poky-tools.bb b/meta/recipes-core/tasks/task-poky-tools.bb
new file mode 100644
index 0000000000..e5d4200eb1
--- /dev/null
+++ b/meta/recipes-core/tasks/task-poky-tools.bb
@@ -0,0 +1,77 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Tools tasks for Poky"
+LICENSE = "MIT"
+PR = "r6"
+
+PACKAGES = "\
+ task-poky-tools-debug \
+ task-poky-tools-debug-dbg \
+ task-poky-tools-debug-dev \
+ task-poky-tools-profile \
+ task-poky-tools-profile-dbg \
+ task-poky-tools-profile-dev \
+ task-poky-tools-testapps \
+ task-poky-tools-testapps-dbg \
+ task-poky-tools-testapps-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+# kexec-tools doesn't work on Mips
+KEXECTOOLS ?= "kexec-tools"
+KEXECTOOLS_mips ?= ""
+KEXECTOOLS_mipsel ?= ""
+KEXECTOOLS_powerpc ?= ""
+
+RDEPENDS_task-poky-tools-debug = "\
+ gdb \
+ gdbserver \
+ tcf-agent \
+ strace"
+
+RDEPENDS_task-poky-tools-profile = "\
+ oprofile \
+ oprofileui-server \
+ powertop \
+ latencytop \
+ lttng-control \
+ lttng-viewer"
+
+RRECOMMENDS_task-poky-tools-profile = "\
+ perf \
+ trace-cmd \
+ kernel-module-oprofile"
+
+# exmap-console
+# exmap-server
+
+# At present we only build lttng-ust on
+# qemux86/qemux86-64/qemuppc/emenlow/netbook since upstream liburcu
+# (which is required by lttng-ust) may not build on other platforms, like
+# MIPS and qemu ARMv5te that poky uses now.
+RDEPENDS_task-poky-tools-profile_append_qemux86 = " valgrind lttng-ust"
+RDEPENDS_task-poky-tools-profile_append_qemux86-64 = " lttng-ust"
+RDEPENDS_task-poky-tools-profile_append_qemuppc = " lttng-ust"
+RDEPENDS_task-poky-tools-profile_append_emenlow = " lttng-ust"
+RDEPENDS_task-poky-tools-profile_append_netbook = " lttng-ust"
+
+RDEPENDS_task-poky-tools-testapps = "\
+ blktool \
+ tslib-calibrate \
+ tslib-tests \
+ lrzsz \
+ ${KEXECTOOLS} \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ owl-video \
+ gst-meta-video \
+ gst-meta-audio \
+ xrestop \
+ xwininfo \
+ xprop \
+ xvideo-tests"
diff --git a/meta/recipes-core/tasks/task-sdk-host.bb b/meta/recipes-core/tasks/task-sdk-host.bb
new file mode 100644
index 0000000000..bccf48dbde
--- /dev/null
+++ b/meta/recipes-core/tasks/task-sdk-host.bb
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd
+#
+
+DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
+PR = "r8"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+inherit nativesdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ binutils-cross-canadian \
+ gdb-cross-canadian \
+ gcc-cross-canadian \
+ pkgconfig-nativesdk \
+ qemu-nativesdk \
+ qemu-helper-nativesdk \
+ pseudo-nativesdk \
+ unfs-server-nativesdk \
+ opkg-nativesdk \
+ "
+
+RDEPENDS_${PN}_darwin8 = "\
+ odcctools-cross-canadian \
+ llvm-cross-canadian \
+ pkgconfig-nativesdk \
+ opkg-nativesdk \
+ libtool-nativesdk \
+ "