aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-03 21:58:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:13:25 +0100
commit5416bf849ceefb49f06bedfa5e67595e9c68582a (patch)
tree6b024235e7a08027fb8a52d38b00e8309256a862 /meta/recipes-core
parent90cfe33d30ef4f9491bd52e7965c5279a2e2650c (diff)
downloadopenembedded-core-contrib-5416bf849ceefb49f06bedfa5e67595e9c68582a.tar.gz
glib-2.0-nativesdk: Add dependency on glib-2.0-native
when we build for nativesdk it needs tools from installed glib-2.0-dev package. We zeroes out compile_resourses but then genmarshal came up so instead of going about disabling them one by one lets depend on glib-2.0-native since thats the right thing to do. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
index 932c9466f5..8f7cd69f82 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
@@ -1,11 +1,11 @@
require glib.inc
-PR = "r3"
+PR = "r4"
PE = "1"
DEPENDS += "libffi python-argparse-native zlib"
DEPENDS_virtclass-native += "libffi-native python-argparse-native"
-DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nativesdk"
+DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nativesdk ${BPN}-native"
SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
@@ -22,7 +22,6 @@ SRC_URI[sha256sum] = "a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b1
SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
BBCLASSEXTEND = "native nativesdk"
-CACHED_CONFIGUREVARS_virtclass-nativesdk = "ac_cv_path_GLIB_COMPILE_RESOURCES=/bin/true"
do_configure_prepend() {
sed -i -e "s:TEST_PROGS += gdbus-serialization::g" ${S}/gio/tests/Makefile.am
sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in