aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-04-03 17:33:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-04 17:17:11 +0100
commit3e4562500956550dbae5467a5fe9289f1d32f775 (patch)
tree3d22fa7f34f98f3b235e6c9ef67d7de01d59d93b /meta/recipes-core
parent603a15bf4c838e4b6352e31f70a958d93f91138f (diff)
downloadopenembedded-core-contrib-3e4562500956550dbae5467a5fe9289f1d32f775.tar.gz
self-hosted-image: Increase space for build and allow builder user sudo access
We need to have about 40G to do a full sato build even with rm_work enabled Add sudo priveleges inorder to allow the builder user to setup the tap/tun devices needed by runqemu Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index 28221892a3..1db6a7a3b2 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -4,15 +4,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r8"
+PR = "r9"
IMAGE_FEATURES += "x11-mini package-management"
-# Ensure there's enough space to do a core-image-minimal build, with rm_work enabled
-IMAGE_ROOTFS_EXTRA_SPACE = "1048576"
-#IMAGE_ROOTFS_EXTRA_SPACE = "2621440"
-#IMAGE_ROOTFS_EXTRA_SPACE = "20971520"
-#IMAGE_ROOTFS_EXTRA_SPACE = "5242880"
+# Ensure there's enough space to do a core-image-sato build, with rm_work enabled
+IMAGE_ROOTFS_EXTRA_SPACE = "41943040"
# Do a quiet boot with limited console messages
APPEND += "quiet"
@@ -50,6 +47,9 @@ fakeroot do_populate_poky_src () {
chown builder.builder ${IMAGE_ROOTFS}/home/builder/pseudo
chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/poky
+
+ # Allow builder to use sudo to setup tap/tun
+ echo "builder ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers
}
IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "