aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-01-30 18:26:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-01 15:53:30 +0000
commit3cef117439aea2d724e92dcb0f862f1cc8e8bfa5 (patch)
tree7b7ca14413ccbcac58f66e050b2ba194f604ba34 /meta/recipes-core
parentb26819c85881e82ee1b5c68840011e78c321f18e (diff)
downloadopenembedded-core-contrib-3cef117439aea2d724e92dcb0f862f1cc8e8bfa5.tar.gz
eglibc: don't list the same path twice in RTLDLIST
Before modifying RTLDLIST in ldd, make sure that it doesn't already contain the right path, thus avoiding duplicate entries in RTLDLIST. [YOCTO #2655] Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.17.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.17.bb b/meta/recipes-core/eglibc/eglibc_2.17.bb
index c1cae4f214..7bdb267eb1 100644
--- a/meta/recipes-core/eglibc/eglibc_2.17.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.17.bb
@@ -1,6 +1,6 @@
require eglibc.inc
-PR = "r1"
+PR = "r2"
DEPENDS += "gperf-native kconfig-frontends-native"
@@ -143,8 +143,11 @@ do_compile () {
echo "Adjust ldd script"
if [ -n "${RTLDLIST}" ]
then
- sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
- sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
+ prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST=\(.*\)$#\1#'`
+ if [ "${prevrtld}" != "${RTLDLIST}" ]
+ then
+ sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
+ fi
fi
}