aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndy Ross <andy.ross@windriver.com>2012-09-18 14:38:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-27 09:46:57 +0100
commit3543d0db691e82098c1da7bf12f43e0c57551a3d (patch)
tree95558342ea7858abb2e7a57b8dfafd708b37e1ec /meta/recipes-core
parentef7e1239b95dbef4e461007d6d0612c27a7919ec (diff)
downloadopenembedded-core-contrib-3543d0db691e82098c1da7bf12f43e0c57551a3d.tar.gz
udev-extraconf: Don't mount root filesystem under /media
The mount.sh handler attempts to prevent already-mounted filesystems from being mounted as dynamic/removable "/media". But it misses the case where the kernel has mounted the root filesystem (e.g. with "root=/dev/sda1"). In that situation, /proc/mounts has a device name of "/dev/root" instead of the proper $DEVNAME string exposed by udev. So we must also test the root filesystem device number vs. the $MAJOR/$MINOR udev tells us. Signed-off-by: Andy Ross <andy.ross@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/udev/udev-extraconf/mount.sh8
-rw-r--r--meta/recipes-core/udev/udev-extraconf_1.0.bb2
2 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-core/udev/udev-extraconf/mount.sh b/meta/recipes-core/udev/udev-extraconf/mount.sh
index 2eb9affcc8..99c76b2530 100644
--- a/meta/recipes-core/udev/udev-extraconf/mount.sh
+++ b/meta/recipes-core/udev/udev-extraconf/mount.sh
@@ -49,8 +49,12 @@ if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
$MOUNT $DEVNAME 2> /dev/null
fi
- # If the device isn't mounted at this point, it isn't configured in fstab
- grep -q "^$DEVNAME " /proc/mounts || automount
+ # If the device isn't mounted at this point, it isn't
+ # configured in fstab (note the root filesystem can show up as
+ # /dev/root in /proc/mounts, so check the device number too)
+ if expr $MAJOR "*" 256 + $MINOR != `stat -c %d /`; then
+ grep -q "^$DEVNAME " /proc/mounts || automount
+ fi
fi
diff --git a/meta/recipes-core/udev/udev-extraconf_1.0.bb b/meta/recipes-core/udev/udev-extraconf_1.0.bb
index 9995899f9e..2c4a4f1976 100644
--- a/meta/recipes-core/udev/udev-extraconf_1.0.bb
+++ b/meta/recipes-core/udev/udev-extraconf_1.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
inherit allarch
-PR = "r6"
+PR = "r7"
SRC_URI = " \
file://automount.rules \