aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-25 14:25:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-26 22:42:00 +0000
commit2864ff6a4b3c3f9b3bbb6d2597243cc5d3715939 (patch)
treed19082aee83252afd998f387e4aeac78b9108c34 /meta/recipes-core
parent54c4b4fd10c104641bb7ae087b2230aa6c6085f8 (diff)
downloadopenembedded-core-contrib-2864ff6a4b3c3f9b3bbb6d2597243cc5d3715939.tar.gz
getVar/setVar cleanups
Complete the bb.data.getVar/setVar replacements with accesses directly to the data store object. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/busybox/busybox.inc10
-rw-r--r--meta/recipes-core/tasks/task-core-sdk.bb4
-rw-r--r--meta/recipes-core/uclibc/uclibc.inc29
3 files changed, 18 insertions, 25 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index 0b74ea6780..b948e2ce6b 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -81,17 +81,15 @@ python () {
if "${OE_DEL}":
d.setVar('configmangle_append', "${OE_DEL}" + "\n")
if "${OE_FEATURES}":
- bb.data.setVar('configmangle_append',
+ d.setVar('configmangle_append',
"/^### DISTRO FEATURES$/a\\\n%s\n\n" %
- ("\\n".join((bb.data.expand("${OE_FEATURES}", d).split("\n")))),
- d)
- bb.data.setVar('configmangle_append',
+ ("\\n".join((bb.data.expand("${OE_FEATURES}", d).split("\n")))))
+ d.setVar('configmangle_append',
"/^### CROSS$/a\\\n%s\n" %
("\\n".join(["CONFIG_CROSS_COMPILER_PREFIX=\"${TARGET_PREFIX}\"",
"CONFIG_EXTRA_CFLAGS=\"${CFLAGS}\""
])
- ),
- d)
+ ))
}
do_prepare_config () {
diff --git a/meta/recipes-core/tasks/task-core-sdk.bb b/meta/recipes-core/tasks/task-core-sdk.bb
index a74de01b07..d940e39318 100644
--- a/meta/recipes-core/tasks/task-core-sdk.bb
+++ b/meta/recipes-core/tasks/task-core-sdk.bb
@@ -80,11 +80,11 @@ RDEPENDS_task-core-sdk = "\
# rreclist.append('%s-dev' % name)
#
# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg) or ''
-# bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d)
+# d.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist))
# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg)))
#
# # bb.note('pkgs is %s' % pkgs)
-# bb.data.setVar('PACKAGES', ' '.join(pkgs), d)
+# d.setVar('PACKAGES', ' '.join(pkgs))
#}
#
#PACKAGES_DYNAMIC = "task-core-sdk-*"
diff --git a/meta/recipes-core/uclibc/uclibc.inc b/meta/recipes-core/uclibc/uclibc.inc
index 8438f25450..92157bdb2a 100644
--- a/meta/recipes-core/uclibc/uclibc.inc
+++ b/meta/recipes-core/uclibc/uclibc.inc
@@ -141,11 +141,10 @@ python () {
if "${OE_DEL}":
d.setVar('configmangle_append', "${OE_DEL}" + "\n")
if "${OE_FEATURES}":
- bb.data.setVar('configmangle_append',
+ d.setVar('configmangle_append',
"/^### DISTRO FEATURES$/a\\\n%s\n\n" %
- ("\\n".join((bb.data.expand("${OE_FEATURES}", d).split("\n")))),
- d)
- bb.data.setVar('configmangle_append',
+ ("\\n".join((bb.data.expand("${OE_FEATURES}", d).split("\n")))))
+ d.setVar('configmangle_append',
"/^### CROSS$/a\\\n%s\n" %
("\\n".join(["CROSS_COMPILER_PREFIX=\"${TARGET_PREFIX}\"",
"UCLIBC_EXTRA_CFLAGS=\"${UCLIBC_EXTRA_CFLAGS}\"",
@@ -154,22 +153,18 @@ python () {
"DEVEL_PREFIX=\"/${prefix}\"",
"SHARED_LIB_LOADER_PREFIX=\"/lib\"",
])
- ),
- d)
- bb.data.setVar('configmangle_append',
+ ))
+ d.setVar('configmangle_append',
"/^### TGT$/a\\\nTARGET_ARCH=\"%s\"\\nTARGET_%s=y\n" %
- ("${UCLIBC_ARCH}", "${UCLIBC_ARCH}"),
- d)
- bb.data.setVar('configmangle_append',
- "/^### FPU$/a\\\n%s\n\n" % (["UCLIBC_HAS_FPU=y","# UCLIBC_HAS_FPU is not set"][d.getVar('TARGET_FPU', 1) in [ 'soft' ]]), d)
+ ("${UCLIBC_ARCH}", "${UCLIBC_ARCH}"))
+ d.setVar('configmangle_append',
+ "/^### FPU$/a\\\n%s\n\n" % (["UCLIBC_HAS_FPU=y","# UCLIBC_HAS_FPU is not set"][d.getVar('TARGET_FPU', True) in [ 'soft' ]]))
if "${UCLIBC_ENDIAN}":
- bb.data.setVar('configmangle_append',
- "/^### ABI$/a\\\nARCH_WANTS_%s_ENDIAN=y\n\n" % ("${UCLIBC_ENDIAN}"),
- d)
+ d.setVar('configmangle_append',
+ "/^### ABI$/a\\\nARCH_WANTS_%s_ENDIAN=y\n\n" % ("${UCLIBC_ENDIAN}"))
if "${UCLIBC_ABI}":
- bb.data.setVar('configmangle_append',
- "/^### ABI$/a\\\nCONFIG_%s=y\n\n" % ("${UCLIBC_ABI}"),
- d)
+ d.setVar('configmangle_append',
+ "/^### ABI$/a\\\nCONFIG_%s=y\n\n" % ("${UCLIBC_ABI}"))
}
do_patch_append() {