aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-05 12:36:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-06 01:12:02 +0100
commit19a13ecceac1f48fcfe1552e88df18edd96e1bea (patch)
treecea21c353d0546f3f0b046c120329e7ebc33a315 /meta/recipes-core
parentc62d6d119c107fc60894ba25e83c96536a1b423c (diff)
downloadopenembedded-core-contrib-19a13ecceac1f48fcfe1552e88df18edd96e1bea.tar.gz
self-hosted-image: use Clearlooks theme
Use a nicer theme (Clearlooks) to improve Hob's appearance in the self hosted image and fix the progress bar not changing colour when the build fails. Fixes [YOCTO #2208] Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb6
-rw-r--r--meta/recipes-core/tasks/task-self-hosted.bb3
2 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index 8adb683744..46e7209336 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -5,7 +5,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r10"
+PR = "r11"
IMAGE_FEATURES += "x11-mini package-management"
@@ -56,6 +56,10 @@ fakeroot do_populate_poky_src () {
# Allow builder to use sudo to setup tap/tun
echo "builder ALL=(ALL) NOPASSWD: ALL" >> ${IMAGE_ROOTFS}/etc/sudoers
+
+ # Use Clearlooks GTK+ theme
+ mkdir -p ${IMAGE_ROOTFS}/etc/gtk-2.0
+ echo 'gtk-theme-name = "Clearlooks"' > ${IMAGE_ROOTFS}/etc/gtk-2.0/gtkrc
}
IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
diff --git a/meta/recipes-core/tasks/task-self-hosted.bb b/meta/recipes-core/tasks/task-self-hosted.bb
index 87928b6c7d..6a24a7fa26 100644
--- a/meta/recipes-core/tasks/task-self-hosted.bb
+++ b/meta/recipes-core/tasks/task-self-hosted.bb
@@ -3,7 +3,7 @@
#
DESCRIPTION = "Create Basic Image Tasks"
-PR = "r7"
+PR = "r8"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -194,4 +194,5 @@ RDEPENDS_task-self-hosted-graphics = "\
libsdl-dev \
libx11-dev \
python-pygtk \
+ gtk-theme-clearlooks \
"