summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-13 22:01:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-16 19:44:45 +0000
commit6012fffa99b600956ea1076d60e050d0737b4c4f (patch)
treea3a9d68430f24595a19c00b0bbe8577602bbd0b1 /meta/recipes-core
parentc58fcc1379ca5755a5b670f79b75e94370d4943c (diff)
downloadopenembedded-core-contrib-6012fffa99b600956ea1076d60e050d0737b4c4f.tar.gz
systemd: Fix reallocarray check
Musl brought this latent issue to fore Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd/0001-meson-Fix-reallocarray-check.patch30
-rw-r--r--meta/recipes-core/systemd/systemd_246.6.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0001-meson-Fix-reallocarray-check.patch b/meta/recipes-core/systemd/systemd/0001-meson-Fix-reallocarray-check.patch
new file mode 100644
index 0000000000..1229dd6e17
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-meson-Fix-reallocarray-check.patch
@@ -0,0 +1,30 @@
+From 1ebf1a1df17afd8b89f84b1928a89069035bf20b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 12 Dec 2020 16:15:57 -0800
+Subject: [PATCH] meson: Fix reallocarray check
+
+reallocarray() is defined in stdlib.h, so that would be right header to
+check for its presense.
+
+Upstream-Status: Submitted [https://github.com/systemd/systemd/pull/17951]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index d205f846c7..e0a3c53529 100644
+--- a/meson.build
++++ b/meson.build
+@@ -517,7 +517,7 @@ foreach ident : [
+ #include <sys/stat.h>
+ #include <unistd.h>'''],
+ ['explicit_bzero' , '''#include <string.h>'''],
+- ['reallocarray', '''#include <malloc.h>'''],
++ ['reallocarray', '''#include <stdlib.h>'''],
+ ['set_mempolicy', '''#include <stdlib.h>
+ #include <unistd.h>'''],
+ ['get_mempolicy', '''#include <stdlib.h>
+--
+2.29.2
+
diff --git a/meta/recipes-core/systemd/systemd_246.6.bb b/meta/recipes-core/systemd/systemd_246.6.bb
index d9e7b1a00c..b89eff6be2 100644
--- a/meta/recipes-core/systemd/systemd_246.6.bb
+++ b/meta/recipes-core/systemd/systemd_246.6.bb
@@ -24,6 +24,7 @@ SRC_URI += "file://touchscreen.rules \
file://0001-systemd.pc.in-use-ROOTPREFIX-without-suffixed-slash.patch \
file://selinux-hook-handling-to-enumerate-nexthop.patch \
file://0001-logind-Restore-chvt-as-non-root-user-without-polkit.patch \
+ file://0001-meson-Fix-reallocarray-check.patch \
"
# patches needed by musl