aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-02 23:47:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-04 00:05:13 +0100
commit894c9b6ded702897ae4084ef75959cdc8cc6f7a3 (patch)
tree8adee5b1bd2db5ed7dfba97bf3d18a4fcbd4172d /meta/recipes-core
parentea3587e626a184c53dc0f484d1a0299b2b00641d (diff)
downloadopenembedded-core-contrib-894c9b6ded702897ae4084ef75959cdc8cc6f7a3.tar.gz
buildtools-tarball/uninative-tarball: Fix for working with populate_sdk under sstate control
Firstly, these recipes are not target (MACHINE) specific so they should by SDK_ARCH based, not PACKAGE_ARCH. Also fix use of SDK_DEPLOY -> SDKDEPOLYDIR after other recent changes. Together these fixes avoid various build failures and ensure the tarballs only get built once rather than multiple times. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb5
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb8
2 files changed, 11 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 34df53191b..e84efabd85 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -26,6 +26,9 @@ TOOLCHAIN_HOST_TASK ?= "\
nativesdk-locale-base-en-us \
"
+MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
+PACKAGE_ARCH = "${SDK_ARCH}"
+
SDK_PACKAGE_ARCHS += "buildtools-dummy-${SDKPKGSUFFIX}"
TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
@@ -40,6 +43,8 @@ inherit meta
inherit populate_sdk
inherit toolchain-scripts
+do_populate_sdk[stamp-extra-info] = ""
+
create_sdk_files_append () {
rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index fb147a17f7..7037bddd4b 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -16,6 +16,9 @@ TOOLCHAIN_HOST_TASK = "\
INHIBIT_DEFAULT_DEPS = "1"
+MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
+PACKAGE_ARCH = "${SDK_ARCH}"
+
TOOLCHAIN_OUTPUTNAME ?= "${SDK_ARCH}-nativesdk-libc"
RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
@@ -29,6 +32,8 @@ deltask install
deltask package
deltask packagedata
+do_populate_sdk[stamp-extra-info] = ""
+
SDK_DEPENDS += "patchelf-native"
SDK_PACKAGING_FUNC = ""
@@ -44,7 +49,6 @@ fakeroot create_sdk_files() {
fakeroot tar_sdk() {
- mkdir -p ${SDK_DEPLOY}
cd ${SDK_OUTPUT}/${SDKPATH}
DEST="./${SDK_ARCH}-${SDK_OS}"
@@ -52,5 +56,5 @@ fakeroot tar_sdk() {
rm sysroots -rf
patchelf --set-interpreter ${@''.join('a' for n in range(1024))} $DEST/usr/bin/patchelf
mv $DEST/usr/bin/patchelf $DEST/usr/bin/patchelf-uninative
- tar ${SDKTAROPTS} -c -j --file=${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
+ tar ${SDKTAROPTS} -c -j --file=${SDKDEPLOYDIR}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
}