aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-13 11:16:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-28 16:56:33 +0000
commit2da88ecbbf118bb7440f48184d4b39c273ab57e9 (patch)
tree4274e4154745dcd885509395bf892f902492bdfe /meta/recipes-core
parent1bd93c625fa64cdddc260fdd164cc0d2c5272ee0 (diff)
downloadopenembedded-core-contrib-2da88ecbbf118bb7440f48184d4b39c273ab57e9.tar.gz
meta: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple attempts at doing so (or simply have re-appeared?). Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) (From OE-Core rev: 9f551d588693328e4d99d33be94f26684eafcaba) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_239.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_239.bb b/meta/recipes-core/systemd/systemd-boot_239.bb
index 312a0145d8..2450d52cb9 100644
--- a/meta/recipes-core/systemd/systemd-boot_239.bb
+++ b/meta/recipes-core/systemd/systemd-boot_239.bb
@@ -29,7 +29,7 @@ EXTRA_OEMESON += "-Defi=true \
python __anonymous () {
import re
target = d.getVar('TARGET_ARCH')
- prefix = "" if d.getVar('EFI_PROVIDER', True) == "systemd-boot" else "systemd-"
+ prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
if target == "x86_64":
systemdimage = prefix + "bootx64.efi"
else: