summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-04 20:37:00 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-05 22:27:33 +0000
commit7930f114aff8e00e777a26656e465f1fe43780b5 (patch)
treeda89a4d885f7a911f478c48522fef3b4343d907d /meta/recipes-core
parent4671011b5b02d0989aa0fdcb50e18cb385a0e95e (diff)
downloadopenembedded-core-contrib-7930f114aff8e00e777a26656e465f1fe43780b5.tar.gz
musl: Update for few bugfixes
We have seen/reported few dlopen related fixes which has been fixed upstream, therefore upgrade all set of changes https://git.musl-libc.org/cgit/musl/log/?qt=range&q=6516282d2adfad2c7e66d854cde3357120c75dbd..43e7efb46555f13a556d92944ac05c19b8929b60 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/musl/musl/out_of_bounds_read.patch20
-rw-r--r--meta/recipes-core/musl/musl_git.bb3
2 files changed, 1 insertions, 22 deletions
diff --git a/meta/recipes-core/musl/musl/out_of_bounds_read.patch b/meta/recipes-core/musl/musl/out_of_bounds_read.patch
deleted file mode 100644
index a681cc284e..0000000000
--- a/meta/recipes-core/musl/musl/out_of_bounds_read.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fix out of bounds read
-
-self->dtv hasn't been extended yet
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-diff --git a/ldso/dynlink.c b/ldso/dynlink.c
-index e2c3259f..b23ea0df 100644
---- a/ldso/dynlink.c
-+++ b/ldso/dynlink.c
-@@ -1374,7 +1376,7 @@ static void install_new_tls(void)
- }
- /* Install new dtls into the enlarged, uninstalled dtv copies. */
- for (p=head; ; p=p->next) {
-- if (!p->tls_id || self->dtv[p->tls_id]) continue;
-+ if (p->tls_id <= old_cnt) continue;
- unsigned char *mem = p->new_tls;
- for (j=0; j<i; j++) {
- unsigned char *new = mem;
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 6a72b7d3bc..2d8dab90dd 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@
require musl.inc
inherit linuxloader
-SRCREV = "6516282d2adfad2c7e66d854cde3357120c75dbd"
+SRCREV = "43e7efb46555f13a556d92944ac05c19b8929b60"
BASEVER = "1.1.21"
@@ -15,7 +15,6 @@ PV = "${BASEVER}+git${SRCPV}"
SRC_URI = "git://git.musl-libc.org/musl \
file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
- file://out_of_bounds_read.patch \
"
S = "${WORKDIR}/git"