summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-20 11:00:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-23 22:13:37 +0100
commita0fb9093733a0e7e3e83f9bcedbd0fcbf6e1a0d3 (patch)
tree0c151c204dbce4991a48b11aa34777fb12a79a2f /meta/recipes-core
parent6cdcb1488a84da6c15145944c2aab3c604252699 (diff)
downloadopenembedded-core-contrib-a0fb9093733a0e7e3e83f9bcedbd0fcbf6e1a0d3.tar.gz
musl-obstack: Add recipe
obstacks from GNUlib is used in some OE-Core packages e.g. elfutils and other packages outside OE-Core, this recipe helps provide this functionality standalone on musl systems, and helps in getting full versions of dependent packages Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/musl/musl-obstack.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/musl-obstack.bb b/meta/recipes-core/musl/musl-obstack.bb
new file mode 100644
index 0000000000..3003935fe5
--- /dev/null
+++ b/meta/recipes-core/musl/musl-obstack.bb
@@ -0,0 +1,22 @@
+# Copyright (C) 2019 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "A standalone library to implement GNU libc's obstack"
+DESCRIPTION = "copy + paste of the obstack functions and macros found in GNU gcc libiberty library for use with musl libc"
+HOMEPAGE = "https://github.com/pullmoll/musl-obstack"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3d23e4eef8243efcaab6f0a438078932"
+SECTION = "libs"
+
+PV = "1.1"
+SRCREV = "d2ad66b0df44a4b784956f7f7f2717131ddc05f4"
+SRC_URI = "git://github.com/pullmoll/musl-obstack"
+
+UPSTREAM_CHECK_COMMITS = "1"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST = ".*-musl.*"
+