summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRicardo Neri <ricardo.neri-calderon@linux.intel.com>2019-07-30 17:20:54 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-08 10:26:40 +0100
commit435d1f8ffe9df86367316d25cb6def2ea2041642 (patch)
tree2026b1be29f07a532ae1172deedd3c1486d17ace /meta/recipes-core
parentb9851d612be842d35ebd78f5f21158beaaed8e64 (diff)
downloadopenembedded-core-contrib-435d1f8ffe9df86367316d25cb6def2ea2041642.tar.gz
ovmf: Use HOSTTOOLS' python3
Use the variable PYTHON_COMMAND to let know EDK2 base tools that python3 in the host shall be used. In order build successfully, the host must have installed the python3-distutils package or equivalent. Based on an original patch by Ross Burton. Cc: Ross Burton <ross.burton@intel.com> Cc: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/ovmf/ovmf_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/ovmf/ovmf_git.bb b/meta/recipes-core/ovmf/ovmf_git.bb
index c66b751a94..834ee32466 100644
--- a/meta/recipes-core/ovmf/ovmf_git.bb
+++ b/meta/recipes-core/ovmf/ovmf_git.bb
@@ -46,6 +46,8 @@ COMPATIBLE_HOST='(i.86|x86_64).*'
OVMF_SECURE_BOOT_EXTRA_FLAGS ??= ""
OVMF_SECURE_BOOT_FLAGS = "-DSECURE_BOOT_ENABLE=TRUE ${OVMF_SECURE_BOOT_EXTRA_FLAGS}"
+export PYTHON_COMMAND = "${HOSTTOOLS_DIR}/python3"
+
do_patch[postfuncs] += "fix_basetools_location"
fix_basetools_location () {
}