aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-18 15:14:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:56:17 +0100
commitab7c1d239b122c8e549e8112c88fd46c9e2b061b (patch)
tree04a9bf8936f064c0e09dd50dbb3564d525468812 /meta/recipes-core
parent9a685d60b0549626cccea5fea8f22a57c2306f81 (diff)
downloadopenembedded-core-contrib-ab7c1d239b122c8e549e8112c88fd46c9e2b061b.tar.gz
meta: Add explict getVar param for (non) expansion
Rather than just use d.getVar(X), use the more explict d.getVar(X, False) since at some point in the future, having the default of expansion would be nice. This is the first step towards that. This patch was mostly made using the command: sed -e 's:\(getVar([^,()]*\)\s*):\1, False):g' -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
index 9b26387e44..5b11861d91 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -71,9 +71,9 @@ RRECOMMENDS_packagegroup-core-sdk = "\
# if packaged('%s-dev' % name, d):
# rreclist.append('%s-dev' % name)
#
-# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg) or ''
+# oldrrec = d.getVar('RRECOMMENDS_%s' % newpkg, False) or ''
# d.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist))
-# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg)))
+# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, d.getVar('RRECOMMENDS_%s' % newpkg, False)))
#
# # bb.note('pkgs is %s' % pkgs)
# d.setVar('PACKAGES', ' '.join(pkgs))