summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/zlib_1.2.11.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-14 12:49:18 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-18 22:59:59 +0000
commit344090a549284d0a1af065ff4cc3038bff8ecfea (patch)
tree38553b4ba170022505c956cedd2a463c12e81a07 /meta/recipes-core/zlib/zlib_1.2.11.bb
parentdb08ec5f48badd5be2fa24cc0d89a4386ab44a59 (diff)
downloadopenembedded-core-contrib-344090a549284d0a1af065ff4cc3038bff8ecfea.tar.gz
zlib: cleanup
Drop remove.ldconfig.call.patch, as it's easier to just set LDCONFIG=true. Pass uname=GNU via the documented configure option instead of undocumented environment variable. Rename zlib-1.2.11/ to just zlib/ as we don't ship multiple versions. Send ldflags-tests.patch upstream and update Upstream-Status. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/zlib_1.2.11.bb')
-rw-r--r--meta/recipes-core/zlib/zlib_1.2.11.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-core/zlib/zlib_1.2.11.bb b/meta/recipes-core/zlib/zlib_1.2.11.bb
index 6410519882..41ec29d95e 100644
--- a/meta/recipes-core/zlib/zlib_1.2.11.bb
+++ b/meta/recipes-core/zlib/zlib_1.2.11.bb
@@ -7,7 +7,6 @@ LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/${BPN}/${PV}/${BPN}-${PV}.tar.xz \
- file://remove.ldconfig.call.patch \
file://Makefile-runtests.patch \
file://ldflags-tests.patch \
file://run-ptest \
@@ -24,7 +23,7 @@ RDEPENDS_${PN}-ptest += "make"
inherit ptest
do_configure() {
- uname=GNU ./configure --prefix=${prefix} --shared --libdir=${libdir}
+ LDCONFIG=true ./configure --prefix=${prefix} --shared --libdir=${libdir} --uname=GNU
}
do_compile() {