aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-13 16:40:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-21 15:00:57 +0000
commitb5c8add7f3ed58451cb460a242b4edd671ba618e (patch)
tree90a5bd33b17737e3f091cd6d76460b2e7d95963c /meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch
parent1da6a2dbd5e7aeea6cd45ca05590bdd50b67bf89 (diff)
downloadopenembedded-core-contrib-b5c8add7f3ed58451cb460a242b4edd671ba618e.tar.gz
zlib: remove ldconfig call from install-libs
* it's called from install-libs target and when /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache (in my case libstdc++.so cannot be found after building zlib(-native) and I have to call touch */libstdc++.so && /sbin/ldconfig to fix it Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch')
-rw-r--r--meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch b/meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch
new file mode 100644
index 0000000000..403b4825c9
--- /dev/null
+++ b/meta/recipes-core/zlib/zlib-1.2.6/remove.ldconfig.call.patch
@@ -0,0 +1,20 @@
+
+When /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache
+(in my case libstdc++.so cannot be found after building zlib(-native) and I have to call
+touch */libstdc++.so && /sbin/ldconfig to fix it.
+
+So remove ldconfig call from make install-libs
+
+Upstream-Status: Inappropriate [disable feature]
+
+diff -uNr zlib-1.2.6.orig/Makefile.in zlib-1.2.6/Makefile.in
+--- zlib-1.2.6.orig/Makefile.in 2012-01-28 23:48:50.000000000 +0100
++++ zlib-1.2.6/Makefile.in 2012-02-13 15:38:20.577700723 +0100
+@@ -199,7 +199,6 @@
+ rm -f $(DESTDIR)$(sharedlibdir)/$(SHAREDLIB) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIBM); \
+ ln -s $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIB); \
+ ln -s $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)/$(SHAREDLIBM); \
+- ($(LDCONFIG) || true) >/dev/null 2>&1; \
+ fi
+ cp zlib.3 $(DESTDIR)$(man3dir)
+ chmod 644 $(DESTDIR)$(man3dir)/zlib.3