aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-03-09 18:00:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 11:44:46 +0000
commitf831d4713a24dd56bf09276fb3b293d9c2b508cb (patch)
treef86e759e343b92b1cb9ef206e783430502205f87 /meta/recipes-core/util-linux
parent76f46391239d3e123cfde900c52ca12ac73fd84f (diff)
downloadopenembedded-core-contrib-f831d4713a24dd56bf09276fb3b293d9c2b508cb.tar.gz
openembedded-core-contrib-f831d4713a24dd56bf09276fb3b293d9c2b508cb.tar.bz2
openembedded-core-contrib-f831d4713a24dd56bf09276fb3b293d9c2b508cb.zip
util-linux: explicitly disable udev
* util-linux auto-detects libudev for lsblk, so disable it, because it's not listed in DEPENDS. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-core/util-linux')
-rw-r--r--meta/recipes-core/util-linux/util-linux.inc2
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.21.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/util-linux/util-linux.inc b/meta/recipes-core/util-linux/util-linux.inc
index 1a3d293fd6b..e2d354f948a 100644
--- a/meta/recipes-core/util-linux/util-linux.inc
+++ b/meta/recipes-core/util-linux/util-linux.inc
@@ -38,7 +38,7 @@ EXTRA_OECONF = "--libdir=${base_libdir} --disable-use-tty-group \
--enable-kill --enable-last --enable-mesg --enable-partx \
--enable-raw --enable-rdev --enable-reset --disable-login-utils \
--enable-write --enable-arch --enable-mount --with-fsprobe=builtin \
- --enable-libuuid --enable-libblkid --enable-fsck"
+ --enable-libuuid --enable-libblkid --enable-fsck --without-udev"
FILES_${PN}-doc += "${datadir}/getopt/getopt-*.*"
diff --git a/meta/recipes-core/util-linux/util-linux_2.21.bb b/meta/recipes-core/util-linux/util-linux_2.21.bb
index 744dbaf58bc..bcf92e0fe9b 100644
--- a/meta/recipes-core/util-linux/util-linux_2.21.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.21.bb
@@ -1,5 +1,5 @@
MAJOR_VERSION = "2.21"
-PR = "r2"
+PR = "r3"
require util-linux.inc
# note that `lscpu' is under GPLv3+