aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-02 12:45:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-06 15:52:16 +0100
commita244bd1a8c98a970979e6bcfbd24c8a5b398ed0e (patch)
tree061081488e6bbc8d0cdd00772e59d34f3a7d0181 /meta/recipes-core/util-linux
parent7efd372eead4185e8b763c6f7ee1943485f7d84d (diff)
downloadopenembedded-core-contrib-a244bd1a8c98a970979e6bcfbd24c8a5b398ed0e.tar.gz
util-linux_2.19.1.bb: Fix compliation on uclibc
util-linux 2.19 needs this patch to successfully compile on uclibc systems. This is a bug in util-linux that goes unnoticed on eglibc builds. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/util-linux')
-rw-r--r--meta/recipes-core/util-linux/util-linux-2.19.1/uclibc-__progname-conflict.patch31
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.19.1.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/meta/recipes-core/util-linux/util-linux-2.19.1/uclibc-__progname-conflict.patch b/meta/recipes-core/util-linux/util-linux-2.19.1/uclibc-__progname-conflict.patch
new file mode 100644
index 0000000000..45826b180a
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux-2.19.1/uclibc-__progname-conflict.patch
@@ -0,0 +1,31 @@
+configure should include errno.h instead of argp.h when
+checking for presence of program_invocation_short_name
+uclibc defines this to be const char* unlike util-linux-ng
+which defines this to be char* so this error goes unnoticed
+on glibc/eglibc systems.
+
+here is the error it fixes
+
+in file included from mountP.h:14:0,
+ from cache.c:29:
+/home/kraj/work/slugos/build/tmp-slugos-uclibc/sysroots/nslu2le/usr/include/errno.h:55:46: error: conflicting types for '__progname'
+../../../include/c.h:118:14: note: previous declaration of '__progname' was here
+make[3]: *** [cache.lo] Error 1
+
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: util-linux-2.19.1/configure.ac
+===================================================================
+--- util-linux-2.19.1.orig/configure.ac
++++ util-linux-2.19.1/configure.ac
+@@ -250,7 +250,7 @@ esac
+
+
+ AC_MSG_CHECKING(whether program_invocation_short_name is defined)
+-AC_TRY_COMPILE([#include <argp.h>],
++AC_TRY_COMPILE([#include <errno.h>],
+ [program_invocation_short_name = "test";],
+ AC_DEFINE(HAVE_PROGRAM_INVOCATION_SHORT_NAME, 1,
+ [Define if program_invocation_short_name is defined])
diff --git a/meta/recipes-core/util-linux/util-linux_2.19.1.bb b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
index 7fe7497eb8..8067ab5ac5 100644
--- a/meta/recipes-core/util-linux/util-linux_2.19.1.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
@@ -6,7 +6,9 @@ require util-linux.inc
LICENSE_util-linux-lscpu = "GPLv3+"
SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
- file://util-linux-ng-2.16-mount_lock_path.patch"
+ file://util-linux-ng-2.16-mount_lock_path.patch \
+ file://uclibc-__progname-conflict.patch \
+"
SRC_URI[md5sum] = "3eab06f05163dfa65479c44e5231932c"
SRC_URI[sha256sum] = "d3eac4afcc687b3ae1ffedcab2dc12df84c7ba7045cce31386d2b7040a011c7d"