aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-11-16 23:01:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-30 15:38:19 +0000
commit9e5c69860e6b687b93e653510ceba8e1f9c6d0f5 (patch)
treea3bddfce3e403205ebd2a106a8a4c7c63cae5bcc /meta/recipes-core/util-linux
parentf218573248168268c143bac7f6304cc76d8d709a (diff)
downloadopenembedded-core-contrib-9e5c69860e6b687b93e653510ceba8e1f9c6d0f5.tar.gz
openembedded-core-contrib-9e5c69860e6b687b93e653510ceba8e1f9c6d0f5.tar.bz2
openembedded-core-contrib-9e5c69860e6b687b93e653510ceba8e1f9c6d0f5.zip
util-linux: use u-a to provide /sbin/getty from util-linux-agetty
* inittab and systemd-serialgetty expects /sbin/getty not agetty Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-core/util-linux')
-rw-r--r--meta/recipes-core/util-linux/util-linux.inc8
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.19.1.bb2
2 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-core/util-linux/util-linux.inc b/meta/recipes-core/util-linux/util-linux.inc
index 855a54572cc..acc4a39c491 100644
--- a/meta/recipes-core/util-linux/util-linux.inc
+++ b/meta/recipes-core/util-linux/util-linux.inc
@@ -236,6 +236,14 @@ pkg_prerm_util-linux-fdisk () {
update-alternatives --remove fdisk fdisk.${PN}
}
+pkg_postinst_util-linux-agetty () {
+ update-alternatives --install ${base_sbindir}/getty getty agetty 100
+}
+
+pkg_prerm_util-linux-agetty () {
+ update-alternatives --remove getty agetty
+}
+
pkg_postinst_util-linux-mount () {
update-alternatives --install ${base_bindir}/mount mount mount.${PN} 100
}
diff --git a/meta/recipes-core/util-linux/util-linux_2.19.1.bb b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
index b65e761b68e..82040eff784 100644
--- a/meta/recipes-core/util-linux/util-linux_2.19.1.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
@@ -1,5 +1,5 @@
MAJOR_VERSION = "2.19"
-PR = "r11"
+PR = "r12"
require util-linux.inc
# note that `lscpu' is under GPLv3+