aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.22.2.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-01-23 13:27:12 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-28 12:25:37 +0000
commitb4ec72a5efe7a22a00aa3ced7eeb2213233b848c (patch)
tree3e9769b63ffca859c98285fc1e8d64fa2732e5dc /meta/recipes-core/util-linux/util-linux_2.22.2.bb
parentfb1a7cf8ac1b5ab8047f47ace28775685ba28804 (diff)
downloadopenembedded-core-contrib-b4ec72a5efe7a22a00aa3ced7eeb2213233b848c.tar.gz
util-linux: Update to 2.22.2
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.22.2.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.22.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.22.2.bb b/meta/recipes-core/util-linux/util-linux_2.22.2.bb
new file mode 100644
index 0000000000..dd9557320c
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux_2.22.2.bb
@@ -0,0 +1,43 @@
+MAJOR_VERSION = "2.22"
+PR = "r0"
+require util-linux.inc
+
+# note that `lscpu' is under GPLv3+
+LICENSE_${PN}-lscpu = "GPLv3+"
+
+SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
+ file://util-linux-ng-2.16-mount_lock_path.patch \
+ file://uclibc-__progname-conflict.patch \
+ file://configure-sbindir.patch \
+ file://fix-configure.patch \
+"
+
+SRC_URI[md5sum] = "3e379b4d8b9693948d751c154614c73e"
+SRC_URI[sha256sum] = "7463a17a01a77cee36d8ce845d8148208f553c9abdd67b446324bf42968bc36d"
+
+# Only lscpu part is gplv3; rest of the code is not,
+# so take out the lscpu parts while running non-gplv3 build.
+# The removal of the package should now occur during
+# the build if INCOMPATIBLE_LICENSE is set to GPLv3
+
+python () {
+ d.setVar("REMOVELSCPU", "no")
+ if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
+ # avoid GPLv3
+ d.setVar("REMOVELSCPU", "yes")
+ src_uri = (d.getVar("SRC_URI", False) or "").split()
+ src_uri.append("file://remove-lscpu.patch")
+ d.setVar("SRC_URI", " ".join(src_uri))
+}
+
+do_remove_lscpu() {
+ if [ "x${REMOVELSCPU}" = "xyes" ]; then
+ rm -f sys-utils/lscpu.c sys-utils/lscpu.1
+ rm -rf tests/ts/lscpu tests/expected/lscpu
+ fi
+}
+
+addtask remove_lscpu before do_configure after do_patch
+
+CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=as"
+EXTRA_OECONF_class-native += "--disable-fallocate --disable-use-tty-group"