aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev
diff options
context:
space:
mode:
authorAlexandra Safta <alexandra.safta@enea.com>2013-12-02 13:39:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-14 09:09:34 +0000
commit34430ecdc4bb7414ca865df1b164bce1e4fec6fa (patch)
tree61903ab52e46edc4f3df319faf572c2a7c3426c1 /meta/recipes-core/udev
parent137ab87de54724f839ae217fd51f870b4ae6b3b3 (diff)
downloadopenembedded-core-contrib-34430ecdc4bb7414ca865df1b164bce1e4fec6fa.tar.gz
udev: Add ptest
Install udev test suite and run it as a ptest. Signed-off-by: Alexandra Safta <alexandra.safta@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/udev')
-rw-r--r--meta/recipes-core/udev/udev.inc8
-rw-r--r--meta/recipes-core/udev/udev/add-install-ptest.patch73
-rw-r--r--meta/recipes-core/udev/udev/run-ptest3
3 files changed, 83 insertions, 1 deletions
diff --git a/meta/recipes-core/udev/udev.inc b/meta/recipes-core/udev/udev.inc
index db09c54843..3190731a6a 100644
--- a/meta/recipes-core/udev/udev.inc
+++ b/meta/recipes-core/udev/udev.inc
@@ -26,9 +26,12 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://local.rules \
file://udev-cache \
file://udev-cache.default \
+ file://add-install-ptest.patch \
+ file://run-ptest \
file://init"
-inherit autotools pkgconfig update-rc.d
+inherit autotools pkgconfig update-rc.d ptest
++RDEPENDS_${PN}-ptest += "make"
libexecdir = "${base_libdir}"
EXTRA_OECONF = "--disable-introspection \
@@ -99,3 +102,6 @@ python () {
if oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
raise bb.parse.SkipPackage("'systemd' in DISTRO_FEATURES")
}
+do_compile_ptest() {
+ oe_runmake test-udev
+}
diff --git a/meta/recipes-core/udev/udev/add-install-ptest.patch b/meta/recipes-core/udev/udev/add-install-ptest.patch
new file mode 100644
index 0000000000..44365c69e6
--- /dev/null
+++ b/meta/recipes-core/udev/udev/add-install-ptest.patch
@@ -0,0 +1,73 @@
+Adjustements for ptest:
+
+- Add 'install-ptest' rule.
+- Print a standard result line for each test.
+- Replace the use of "tree" with "find".
+
+Signed-off-by: Björn Stenberg <bjst@enea.com>
+Signed-off-by: Alexandra Safta <alst@enea.com>
+Upstream-status: Pending
+
+--- a/Makefile.am 2012-03-18 16:28:14.000000000 +0100
++++ b/Makefile.am 2013-02-18 10:03:36.531101244 +0100
+@@ -708,3 +708,11 @@
+ for i in src/docs/html/*.{html,css,png}; do echo $$i; kup put $$i $$i.sign /pub/linux/utils/kernel/hotplug/libudev/; done
+ for i in src/gudev/docs/html/*.{html,css,png}; do rm -f $$i.sign; gpg --armor --detach-sign --output=$$i.sign $$i; done
+ for i in src/gudev/docs/html/*.{html,css,png}; do echo $$i; kup put $$i $$i.sign /pub/linux/utils/kernel/hotplug/gudev/; done
++
++install-ptest:
++ install test-udev $(DESTDIR)
++ cp Makefile $(DESTDIR)
++ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/Makefile
++ $(MKDIR_P) $(DESTDIR)/test
++ (cd $(top_srcdir) && install $(TESTS) $(DESTDIR)/test)
++ tar -C $(DESTDIR)/test/ -xJf $(top_srcdir)/test/sys.tar.xz
+--- a/test/udev-test.pl 2012-03-18 16:43:36.000000000 +0100
++++ b/test/udev-test.pl 2013-02-18 10:31:29.706357321 +0100
+@@ -1459,11 +1459,13 @@
+ print "add: error";
+ if ($rules->{exp_add_error}) {
+ print " as expected\n";
++ print "XFAIL: TEST $number: $rules->{desc}: add\n";
+ } else {
+ print "\n";
+- system("tree $udev_root");
++ system("find $udev_root");
+ print "\n";
+ $error++;
++ print "FAIL: TEST $number: $rules->{desc}: add\n";
+ sleep(1);
+ }
+ }
+@@ -1479,15 +1481,18 @@
+ print "remove: error";
+ if ($rules->{exp_rem_error}) {
+ print " as expected\n";
++ print "XFAIL: TEST $number: $rules->{desc}: remove\n";
+ } else {
+ print "\n";
+- system("tree $udev_root");
++ system("find $udev_root");
+ print "\n";
+ $error++;
++ print "FAIL: TEST $number: $rules->{desc}: remove\n";
+ sleep(1);
+ }
+ } else {
+ print "remove: ok\n";
++ print "PASS: TEST $number: $rules->{desc}: remove\n";
+ }
+
+ print "\n";
+--- a/configure.ac 2013-11-28 09:14:02.814248826 +0100
++++ b/configure.ac 2013-11-28 09:14:34.260874296 +0100
+@@ -6,7 +6,7 @@
+ [http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html])
+ AC_CONFIG_SRCDIR([src/udevd.c])
+ AC_CONFIG_AUX_DIR([build-aux])
+-AM_INIT_AUTOMAKE([check-news foreign 1.11 -Wall -Wno-portability silent-rules tar-pax no-dist-gzip dist-xz subdir-objects])
++AM_INIT_AUTOMAKE([check-news foreign 1.11 -Wall -Wno-portability silent-rules tar-pax no-dist-gzip dist-xz subdir-objects serial-tests])
+ AC_USE_SYSTEM_EXTENSIONS
+ AC_SYS_LARGEFILE
+ AC_CONFIG_MACRO_DIR([m4])
+
diff --git a/meta/recipes-core/udev/udev/run-ptest b/meta/recipes-core/udev/udev/run-ptest
new file mode 100644
index 0000000000..6817ef70e6
--- /dev/null
+++ b/meta/recipes-core/udev/udev/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+make -k check-TESTS \ No newline at end of file