summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2024-01-31 10:53:42 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-03 21:52:15 +0000
commitdc7cd56df85f28f2a3a3dd97730d475522b7b0f7 (patch)
tree06d0c88bc84d91d62cfa7bc0ea0fb75e69e9954e /meta/recipes-core/udev
parentf740aa48c34c0abd01b6a506ba6951890ee9415f (diff)
downloadopenembedded-core-contrib-dc7cd56df85f28f2a3a3dd97730d475522b7b0f7.tar.gz
eudev: allow for predictable network interface names
Do not suppress renaming by eudev if 'pni-names' is a distro feature. The previous behavior was to always suppress renaming. eudev is used when sysvinit is the init manager. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/udev')
-rw-r--r--meta/recipes-core/udev/eudev_3.2.14.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/udev/eudev_3.2.14.bb b/meta/recipes-core/udev/eudev_3.2.14.bb
index ddb3c3340f..18696679c8 100644
--- a/meta/recipes-core/udev/eudev_3.2.14.bb
+++ b/meta/recipes-core/udev/eudev_3.2.14.bb
@@ -49,9 +49,10 @@ do_install:append() {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
- # Use classic network interface naming scheme
- touch ${D}${sysconfdir}/udev/rules.d/80-net-name-slot.rules
-
+ # Use classic network interface naming scheme if no 'pni-names' distro feature
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'pni-names', 'false', 'true', d)}; then
+ touch ${D}${sysconfdir}/udev/rules.d/80-net-name-slot.rules
+ fi
}
do_install:prepend:class-target () {