summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-11-29 20:49:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-04 11:23:33 +0000
commit2e0f552cac05c2b9f5a80ac396374a7987238a34 (patch)
treebaa7bad40ef34a11d5ebde387a335c79ec72d5be /meta/recipes-core/udev
parent645370e85d8742d0614cd52ca7507b5df2d38ad8 (diff)
downloadopenembedded-core-contrib-2e0f552cac05c2b9f5a80ac396374a7987238a34.tar.gz
eudev: Upgrade 3.2.12 -> 3.2.14
Drop merged patches: 0001-Export-dummies-for.patch 0002-Bump-udev-version-to-251.patch Boian Bonev (13): Update as per IRC discussion Bump udev version to 251 Export dummies for bump version to 3.2.14 Fix := not preventing further assignments to RUN Add /usr/local/lib/udev/rules.d Move the changes from udev.7 to udev.xml Regenerate according to 0cf14fb and e5e4013 Improve wording and restore lines lost in merges Improve wording Tabs to spaces Ensure that standard file descriptors are open Commit the generated man page NaofumiHonda (1): Clear sysattr cache if a null pointer is passed (#255) Vivien Kraus (6): Let libudev find hwdb.bin under UDEV_HWDB_BIN Add a generic --output argument to udevadm hwdb Dynamically get the udevadm hwdb files with a path variable fixup! Dynamically get the udevadm hwdb files with a path variable Remove references to /run/udev/hwdb.d Clarify the /etc/udev/hwdb.d file override with respect to UDEV_HWDB_PATH Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/udev')
-rw-r--r--meta/recipes-core/udev/eudev/0001-Export-dummies-for.patch82
-rw-r--r--meta/recipes-core/udev/eudev/0002-Bump-udev-version-to-251.patch23
-rw-r--r--meta/recipes-core/udev/eudev_3.2.14.bb (renamed from meta/recipes-core/udev/eudev_3.2.12.bb)4
3 files changed, 1 insertions, 108 deletions
diff --git a/meta/recipes-core/udev/eudev/0001-Export-dummies-for.patch b/meta/recipes-core/udev/eudev/0001-Export-dummies-for.patch
deleted file mode 100644
index 21fbf0f824..0000000000
--- a/meta/recipes-core/udev/eudev/0001-Export-dummies-for.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 45634cc0f09ea354be7efce2ae3d3fa8ffc181ec Mon Sep 17 00:00:00 2001
-From: Boian Bonev <bbonev@ipacct.com>
-Date: Fri, 11 Aug 2023 23:14:02 +0000
-Subject: [PATCH] Export dummies for
-
- - udev_device_has_current_tag
- - udev_device_get_current_tags_list_entry
-
-since the current eudev device database does not support the concept of
-current tags
-
-Upstream-Status: Submitted [https://github.com/eudev-project/eudev/pull/253]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- src/libudev/libudev-device.c | 11 +++++++++++
- src/libudev/libudev.h | 2 ++
- src/libudev/libudev.sym | 6 ++++++
- 3 files changed, 19 insertions(+)
-
-diff --git a/src/libudev/libudev-device.c b/src/libudev/libudev-device.c
-index ac67ce8..7d7a662 100644
---- a/src/libudev/libudev-device.c
-+++ b/src/libudev/libudev-device.c
-@@ -1819,6 +1819,12 @@ _public_ struct udev_list_entry *udev_device_get_tags_list_entry(struct udev_dev
- return udev_list_get_entry(&udev_device->tags_list);
- }
-
-+_public_ struct udev_list_entry *udev_device_get_current_tags_list_entry(struct udev_device *udev_device)
-+{
-+ // TODO: eudev database does not support current tags
-+ return udev_device_get_tags_list_entry(udev_device);
-+}
-+
- /**
- * udev_device_has_tag:
- * @udev_device: udev device
-@@ -1842,6 +1848,11 @@ _public_ int udev_device_has_tag(struct udev_device *udev_device, const char *ta
- return false;
- }
-
-+_public_ int udev_device_has_current_tag(struct udev_device *udev_device, const char *tag) {
-+ // TODO: eudev database does not support current tags
-+ return udev_device_has_tag(udev_device, tag);
-+}
-+
- #define ENVP_SIZE 128
- #define MONITOR_BUF_SIZE 4096
- static int update_envp_monitor_buf(struct udev_device *udev_device)
-diff --git a/src/libudev/libudev.h b/src/libudev/libudev.h
-index 8491d2b..0202964 100644
---- a/src/libudev/libudev.h
-+++ b/src/libudev/libudev.h
-@@ -100,6 +100,7 @@ int udev_device_get_is_initialized(struct udev_device *udev_device);
- struct udev_list_entry *udev_device_get_devlinks_list_entry(struct udev_device *udev_device);
- struct udev_list_entry *udev_device_get_properties_list_entry(struct udev_device *udev_device);
- struct udev_list_entry *udev_device_get_tags_list_entry(struct udev_device *udev_device);
-+struct udev_list_entry *udev_device_get_current_tags_list_entry(struct udev_device *udev_device);
- struct udev_list_entry *udev_device_get_sysattr_list_entry(struct udev_device *udev_device);
- const char *udev_device_get_property_value(struct udev_device *udev_device, const char *key);
- const char *udev_device_get_driver(struct udev_device *udev_device);
-@@ -110,6 +111,7 @@ unsigned long long int udev_device_get_usec_since_initialized(struct udev_device
- const char *udev_device_get_sysattr_value(struct udev_device *udev_device, const char *sysattr);
- int udev_device_set_sysattr_value(struct udev_device *udev_device, const char *sysattr, char *value);
- int udev_device_has_tag(struct udev_device *udev_device, const char *tag);
-+int udev_device_has_current_tag(struct udev_device *udev_device, const char *tag);
-
- /*
- * udev_monitor
-diff --git a/src/libudev/libudev.sym b/src/libudev/libudev.sym
-index 76726fc..d56c2ae 100644
---- a/src/libudev/libudev.sym
-+++ b/src/libudev/libudev.sym
-@@ -118,3 +118,9 @@ global:
- udev_queue_flush;
- udev_queue_get_fd;
- } LIBUDEV_199;
-+
-+LIBUDEV_247 {
-+global:
-+ udev_device_has_current_tag;
-+ udev_device_get_current_tags_list_entry;
-+} LIBUDEV_215;
diff --git a/meta/recipes-core/udev/eudev/0002-Bump-udev-version-to-251.patch b/meta/recipes-core/udev/eudev/0002-Bump-udev-version-to-251.patch
deleted file mode 100644
index 520cc38cda..0000000000
--- a/meta/recipes-core/udev/eudev/0002-Bump-udev-version-to-251.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 7a66d4fe8aac8c8697c3cecb0c189e22524fbc98 Mon Sep 17 00:00:00 2001
-From: Boian Bonev <bbonev@ipacct.com>
-Date: Fri, 11 Aug 2023 22:08:27 +0000
-Subject: [PATCH] Bump udev version to 251
-
-Upstream-Status: Submitted [https://github.com/eudev-project/eudev/pull/253]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 3e31b0e..069fdfb 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,6 +1,6 @@
- AC_PREREQ([2.68])
- AC_INIT([eudev],[3.2.12],[https://github.com/gentoo/eudev/issues])
--AC_SUBST(UDEV_VERSION, 243)
-+AC_SUBST(UDEV_VERSION, 251)
- AC_CONFIG_SRCDIR([src/udev/udevd.c])
-
- AC_USE_SYSTEM_EXTENSIONS
diff --git a/meta/recipes-core/udev/eudev_3.2.12.bb b/meta/recipes-core/udev/eudev_3.2.14.bb
index e19c6c0faa..d0758691bd 100644
--- a/meta/recipes-core/udev/eudev_3.2.12.bb
+++ b/meta/recipes-core/udev/eudev_3.2.14.bb
@@ -12,11 +12,9 @@ PROVIDES = "udev"
SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
file://init \
file://local.rules \
- file://0001-Export-dummies-for.patch \
- file://0002-Bump-udev-version-to-251.patch \
"
-SRC_URI[sha256sum] = "ccdd64ec3c381d3c3ed0e99d2e70d1f62988c7763de89ca7bdffafa5eacb9ad8"
+SRC_URI[sha256sum] = "8da4319102f24abbf7fff5ce9c416af848df163b29590e666d334cc1927f006f"
GITHUB_BASE_URI = "https://github.com/eudev-project/eudev/releases"