aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tinylogin/tinylogin-1.4
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-16 13:51:09 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-09-17 11:41:58 -0700
commit0ff070bbf1575be62691eea7b9fb3ca74f2ab373 (patch)
tree225ec6b34647a07998183aff261c1afde493740c /meta/recipes-core/tinylogin/tinylogin-1.4
parent8e9caafd0b94016568dfccf969a0e326f3645fa6 (diff)
downloadopenembedded-core-contrib-0ff070bbf1575be62691eea7b9fb3ca74f2ab373.tar.gz
gcc: upgrade gcc for powerpc to version 4.5.0
Fix one parameter order issue for base_contains function, which impacts glibc build under new gcc. Add new judge code to determine whether <altivec.h> is needed. This fixes the mpeg2dec build failure under new gcc. Use O2 as the optimization flag to tinylogin as it will meet segfault if compiled by gcc-4.5.0 when enable both frename-registers and Os options. Use O2 instead. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-core/tinylogin/tinylogin-1.4')
-rw-r--r--meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch b/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch
new file mode 100644
index 0000000000..dc5bc3f123
--- /dev/null
+++ b/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch
@@ -0,0 +1,19 @@
+tinylogin will meet segment fault if compiled by gcc-4.5.0 when enable both
+frename-registers and Os options. Use O2 instead.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN tinylogin-1.4-orig/Makefile tinylogin-1.4/Makefile
+--- tinylogin-1.4-orig/Makefile 2010-09-16 13:02:06.302192295 +0800
++++ tinylogin-1.4/Makefile 2010-09-16 13:02:34.634167846 +0800
+@@ -97,9 +97,7 @@
+ #--------------------------------------------------------
+
+
+-# use '-Os' optimization if available, else use -O2
+-OPTIMIZATION = $(shell if $(CC) -Os -S -o /dev/null -xc /dev/null >/dev/null 2>&1; \
+- then echo "-Os"; else echo "-O2" ; fi)
++OPTIMIZATION = -O2
+
+ WARNINGS = -Wall
+