aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-08-05 13:48:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-05 17:30:13 +0100
commitf3d8fd28d779ff841410e5bd22289680f04022a2 (patch)
treec4a0e6fd43f766ffdf66f891963960ce0dd51720 /meta/recipes-core/tasks
parentc96bf9197e1e6566ec7a4cd6b92499fb82c9c697 (diff)
downloadopenembedded-core-contrib-f3d8fd28d779ff841410e5bd22289680f04022a2.tar.gz
task-core-boot.bb: Add PACKAGE definition to facilitate multilib
If there is no PACKAGES defined in bb file, its default definition would be "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev ${PN}-staticdev ${PN}-locale". In multilib case, ${PN} is extended with ${MLPREFIX}, so there is no rename occurred for the PACKAGES. Therefore for task-core-boot, RDEPENDS_lib32-task-core-boot will be empty, resulting busybox, tinylogin, etc. are not bulit out. This fixed the issue that /bin/sh is not provided while do_rootfs. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tasks')
-rw-r--r--meta/recipes-core/tasks/task-core-boot.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/tasks/task-core-boot.bb b/meta/recipes-core/tasks/task-core-boot.bb
index 5aea77169f..eb2b5484a2 100644
--- a/meta/recipes-core/tasks/task-core-boot.bb
+++ b/meta/recipes-core/tasks/task-core-boot.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS = "virtual/kernel"
ALLOW_EMPTY = "1"
-PR = "r7"
+PR = "r8"
#
# Set by the machine configuration with packages essential for device bootup
@@ -17,6 +17,12 @@ PR = "r7"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+PACKAGES = "\
+ task-core-boot \
+ task-core-boot-dbg \
+ task-core-boot-dev \
+"
+
RDEPENDS_task-core-boot = "\
base-files \
base-passwd \