aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-20 17:13:37 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:14 -0800
commit180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6 (patch)
tree16573db8f7b8a75e8cf59dc15c321f889e1edf79 /meta/recipes-core/tasks
parentaa6293ffbc7f8f17e55f2105de56384e14591b44 (diff)
downloadopenembedded-core-contrib-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.tar.gz
task-core-tools: Divide it into 3 recipes
task-core-tools-debug, task-core-tools-profile, task-core-tools-testapps otherwise if we choose one through PACKAGE_GROUPS all packages are built since they are in same recipe. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/tasks')
-rw-r--r--meta/recipes-core/tasks/task-core-tools-debug.bb26
-rw-r--r--meta/recipes-core/tasks/task-core-tools-profile.bb69
-rw-r--r--meta/recipes-core/tasks/task-core-tools-testapps.bb46
-rw-r--r--meta/recipes-core/tasks/task-core-tools.bb102
4 files changed, 141 insertions, 102 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools-debug.bb b/meta/recipes-core/tasks/task-core-tools-debug.bb
new file mode 100644
index 0000000000..3c92f3f8f3
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-debug.bb
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Debug tools tasks for OE-Core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dbg \
+ ${PN}-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_${PN} = "\
+ gdb \
+ gdbserver \
+ tcf-agent \
+ rsync \
+ strace \
+ "
diff --git a/meta/recipes-core/tasks/task-core-tools-profile.bb b/meta/recipes-core/tasks/task-core-tools-profile.bb
new file mode 100644
index 0000000000..254d3f5e48
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-profile.bb
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Profile tools tasks for OE-Core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dbg \
+ ${PN}-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+RRECOMMENDS_${PN} = "\
+ perf \
+ trace-cmd \
+ kernel-module-oprofile \
+ blktrace \
+ sysprof \
+ "
+
+PROFILETOOLS = "\
+ oprofile \
+ oprofileui-server \
+ powertop \
+ latencytop \
+ lttng-control \
+ lttng-viewer"
+
+# systemtap needs elfutils which is not fully buildable on uclibc
+# hence we exclude it from uclibc based builds
+SYSTEMTAP = "systemtap"
+SYSTEMTAP_libc-uclibc = ""
+
+# lttng-ust uses sched_getcpu() which is not there on uclibc
+# for some of the architectures it can be patched to call the
+# syscall directly but for x86_64 __NR_getcpu is a vsyscall
+# which means we can not use syscall() to call it. So we ignore
+# it for x86_64/uclibc
+
+LTTNGUST = "lttng-ust"
+LTTNGUST_libc-uclibc = ""
+LTTNGUST_mips = ""
+
+# valgrind does not work on mips
+
+VALGRIND = "valgrind"
+VALGRIND_libc-uclibc = ""
+VALGRIND_mips = ""
+
+# exmap-console
+# exmap-server
+
+# At present we only build lttng-ust on
+# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
+# (which is required by lttng-ust) may not build on other platforms, like
+# MIPS.
+RDEPENDS_${PN} = "\
+ ${PROFILETOOLS} \
+ ${LTTNGUST} \
+ ${SYSTEMTAP} \
+ ${VALGRIND} \
+ "
diff --git a/meta/recipes-core/tasks/task-core-tools-testapps.bb b/meta/recipes-core/tasks/task-core-tools-testapps.bb
new file mode 100644
index 0000000000..b5847f8b80
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-testapps.bb
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Test apps task for OE-Core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dbg \
+ ${PN}-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+# kexec-tools doesn't work on Mips
+KEXECTOOLS ?= "kexec"
+KEXECTOOLS_mips ?= ""
+KEXECTOOLS_mipsel ?= ""
+KEXECTOOLS_powerpc ?= ""
+
+RDEPENDS_${PN} = "\
+ blktool \
+ fstests \
+ tslib-calibrate \
+ tslib-tests \
+ lrzsz \
+ ${KEXECTOOLS} \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ owl-video \
+ gst-meta-video \
+ gst-meta-audio \
+ mesa-demos \
+ x11perf \
+ xrestop \
+ xwininfo \
+ xprop \
+ xvideo-tests \
+ clutter-box2d \
+ ltp \
+ "
diff --git a/meta/recipes-core/tasks/task-core-tools.bb b/meta/recipes-core/tasks/task-core-tools.bb
deleted file mode 100644
index 1a42f15bdc..0000000000
--- a/meta/recipes-core/tasks/task-core-tools.bb
+++ /dev/null
@@ -1,102 +0,0 @@
-#
-# Copyright (C) 2008 OpenedHand Ltd.
-#
-
-DESCRIPTION = "Tools tasks for OE-Core"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r15"
-
-PACKAGES = "\
- task-core-tools-debug \
- task-core-tools-debug-dbg \
- task-core-tools-debug-dev \
- task-core-tools-profile \
- task-core-tools-profile-dbg \
- task-core-tools-profile-dev \
- task-core-tools-testapps \
- task-core-tools-testapps-dbg \
- task-core-tools-testapps-dev \
- "
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-ALLOW_EMPTY = "1"
-
-# kexec-tools doesn't work on Mips
-KEXECTOOLS ?= "kexec"
-KEXECTOOLS_mips ?= ""
-KEXECTOOLS_mipsel ?= ""
-KEXECTOOLS_powerpc ?= ""
-
-RDEPENDS_task-core-tools-debug = "\
- gdb \
- gdbserver \
- tcf-agent \
- rsync \
- strace"
-
-RDEPENDS_task-core-tools-profile = "\
- oprofile \
- oprofileui-server \
- powertop \
- latencytop \
- lttng-control \
- lttng-viewer"
-
-RRECOMMENDS_task-core-tools-profile = "\
- perf \
- trace-cmd \
- kernel-module-oprofile \
- blktrace \
- sysprof \
- "
-
-# systemtap needs elfutils which is not fully buildable on uclibc
-# hence we exclude it from uclibc based builds
-SYSTEMTAP = "systemtap"
-SYSTEMTAP_libc-uclibc = ""
-
-# lttng-ust uses sched_getcpu() which is not there on uclibc
-# for some of the architectures it can be patched to call the
-# syscall directly but for x86_64 __NR_getcpu is a vsyscall
-# which means we can not use syscall() to call it. So we ignore
-# it for x86_64/uclibc
-
-LTTNGUST = "lttng-ust"
-LTTNGUST_libc-uclibc = ""
-
-# exmap-console
-# exmap-server
-
-# At present we only build lttng-ust on
-# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
-# (which is required by lttng-ust) may not build on other platforms, like
-# MIPS.
-RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust ${SYSTEMTAP}"
-RDEPENDS_task-core-tools-profile_append_qemux86-64 = " ${LTTNGUST} ${SYSTEMTAP}"
-RDEPENDS_task-core-tools-profile_append_qemuppc = " ${LTTNGUST} ${SYSTEMTAP}"
-RDEPENDS_task-core-tools-profile_append_qemuarm = " ${LTTNGUST} ${SYSTEMTAP}"
-
-RDEPENDS_task-core-tools-testapps = "\
- blktool \
- fstests \
- tslib-calibrate \
- tslib-tests \
- lrzsz \
- ${KEXECTOOLS} \
- alsa-utils-amixer \
- alsa-utils-aplay \
- owl-video \
- gst-meta-video \
- gst-meta-audio \
- mesa-demos \
- x11perf \
- xrestop \
- xwininfo \
- xprop \
- xvideo-tests \
- clutter-box2d \
- ltp \
- "