aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-self-hosted.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-11-03 13:11:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-29 11:19:53 +0000
commitd29b2ddb532a59143fe160251e57c9216a3c720d (patch)
treea90df0b2ce98ef862fc6c6e64831b7523b3ed247 /meta/recipes-core/tasks/task-self-hosted.bb
parent264fb6c5a4875cd8969a24a9f0301ed916ab827b (diff)
downloadopenembedded-core-contrib-d29b2ddb532a59143fe160251e57c9216a3c720d.tar.gz
Self Hosted Image: Added Task and Images
This is the first pass of creating a self hosted image, this task and image can pass bitbake's sanity check (if modified to remove the cvs check) and can build psuedo, albit very slowly on qemu. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-core/tasks/task-self-hosted.bb')
-rw-r--r--meta/recipes-core/tasks/task-self-hosted.bb174
1 files changed, 174 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-self-hosted.bb b/meta/recipes-core/tasks/task-self-hosted.bb
new file mode 100644
index 0000000000..c218f43ad6
--- /dev/null
+++ b/meta/recipes-core/tasks/task-self-hosted.bb
@@ -0,0 +1,174 @@
+#
+# Copyright (C) 2010 Intel Corporation
+#
+
+DESCRIPTION = "Create Basic Image Tasks"
+PR = "r0"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ task-self-hosted \
+ task-self-hosted-debug \
+ task-self-hosted-sdk \
+ task-self-hosted-extended \
+ task-self-hosted-graphics \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-self-hosted = "\
+ task-self-hosted-debug \
+ task-self-hosted-sdk \
+ task-self-hosted-extended \
+ task-self-hosted-graphics \
+ "
+
+# eglibc-utils: for rpcgen
+RDEPENDS_task-self-hosted-sdk = "\
+ sed \
+ mktemp \
+ eglibc-utils \
+ autoconf \
+ automake \
+ binutils-symlinks \
+ binutils \
+ cpp \
+ cpp-symlinks \
+ ccache \
+ gcc \
+ gcc-symlinks \
+ g++ \
+ g++-symlinks \
+ gettext \
+ make \
+ intltool \
+ libstdc++ \
+ libstdc++-dev \
+ libtool \
+ perl-module-re \
+ perl-module-text-wrap \
+ coreutils \
+ diffutils \
+ pkgconfig \
+ findutils \
+ quilt \
+ less \
+ distcc \
+ ldd \
+ file \
+ tcl \
+ "
+
+RDEPENDS_task-self-hosted-debug = " \
+ gdb \
+ gdbserver \
+ tcf-agent \
+ rsync \
+ strace"
+
+
+RDEPENDS_task-self-hosted-extended = "\
+ binutils \
+ bzip2 \
+ chkconfig \
+ chrpath \
+ curl \
+ dhcp-client \
+ diffstat \
+ diffutils \
+ elfutils \
+ expat \
+ gamin \
+ gdbm \
+ git \
+ gettext \
+ gettext-runtime \
+ grep \
+ groff \
+ gawk \
+ hdparm \
+ libaio \
+ libxml2 \
+ libusb1 \
+ lrzsz \
+ lsof \
+ lzo \
+ man \
+ man-pages \
+ mc \
+ mdadm \
+ minicom \
+ mtools \
+ ncurses \
+ neon \
+ openssl \
+ opkg \
+ opkg-utils \
+ parted \
+ patch \
+ perl \
+ perl-modules \
+ perl-dev \
+ pth \
+ python \
+ python-compile \
+ python-compiler \
+ python-core \
+ python-curses \
+ python-datetime \
+ python-distutils \
+ python-elementtree \
+ python-fcntl \
+ python-logging \
+ python-misc \
+ python-multiprocessing \
+ python-netclient \
+ python-netserver \
+ python-pickle \
+ python-re \
+ python-rpm \
+ python-shell \
+ python-sqlite3 \
+ python-subprocess \
+ python-textutils \
+ python-xmlrpc \
+ python-email \
+ python-unixadmin \
+ python-compression \
+ quota \
+ readline \
+ rpm \
+ screen \
+ setserial \
+ strace \
+ subversion \
+ sysstat \
+ tar \
+ gzip \
+ tcl \
+ texi2html \
+ texinfo \
+ usbutils \
+ unzip \
+ watchdog \
+ wget \
+ which \
+ xinetd \
+ zip \
+ zlib \
+ cpio \
+ "
+
+
+RDEPENDS_task-self-hosted-graphics = "\
+ python-pygtk \
+ mesa-dri \
+ mesa-dri-dev \
+ libglu \
+ libglu-dev \
+ libsdl \
+ libsdl-dev \
+ libx11-dev \
+ "