aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-tools-debug.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-20 17:13:37 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:14 -0800
commit180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6 (patch)
tree16573db8f7b8a75e8cf59dc15c321f889e1edf79 /meta/recipes-core/tasks/task-core-tools-debug.bb
parentaa6293ffbc7f8f17e55f2105de56384e14591b44 (diff)
downloadopenembedded-core-contrib-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.tar.gz
task-core-tools: Divide it into 3 recipes
task-core-tools-debug, task-core-tools-profile, task-core-tools-testapps otherwise if we choose one through PACKAGE_GROUPS all packages are built since they are in same recipe. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/tasks/task-core-tools-debug.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-tools-debug.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools-debug.bb b/meta/recipes-core/tasks/task-core-tools-debug.bb
new file mode 100644
index 0000000000..3c92f3f8f3
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-debug.bb
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Debug tools tasks for OE-Core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dbg \
+ ${PN}-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_${PN} = "\
+ gdb \
+ gdbserver \
+ tcf-agent \
+ rsync \
+ strace \
+ "