aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-console.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-09-14 17:19:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:20:38 +0100
commit07407baafb728c5ae1bb283f5b02a2ac773360bc (patch)
treebb47ceee79b5600e68f8530c407c440c8360a6d1 /meta/recipes-core/tasks/task-core-console.bb
parenteaef15630c38b8dd60f83df766e6b17cb3838130 (diff)
downloadopenembedded-core-contrib-07407baafb728c5ae1bb283f5b02a2ac773360bc.tar.gz
task-core: split into task-core-console and task-core-x11
[YOCTO #1481] Since tasks are referred to almost exclusively via RDEPENDS, and bitbake will build an entire task recipe when only one of its task packages are actually needed, building a console-only image that uses task-core-apps-console (or less directly, has apps-console in its IMAGE_FEATURES) will cause a build of a whole list of X11 applications that aren't needed. Splitting the task-core recipe into X11 and console portions prevents this issue. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/tasks/task-core-console.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-console.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-console.bb b/meta/recipes-core/tasks/task-core-console.bb
new file mode 100644
index 0000000000..cb2273294f
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-console.bb
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core console applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r35"
+
+PACKAGES = "\
+ task-core-apps-console \
+ task-core-apps-console-dbg \
+ task-core-apps-console-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+SPLASH ?= "psplash"
+
+RDEPENDS_task-core-apps-console = "\
+ avahi-daemon \
+ dbus \
+ portmap \
+ ${SPLASH}"
+