aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/sysvinit
diff options
context:
space:
mode:
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>2013-10-07 15:05:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-14 16:54:27 +0100
commitb00b9ae5693e04cacd0843c12a529e7f3dc501ed (patch)
treee3273b982e4a71f958a8ad16c285fb1215fa575a /meta/recipes-core/sysvinit
parent63edb6b9a8bdf2f5541edd618f2f598185e37223 (diff)
downloadopenembedded-core-contrib-b00b9ae5693e04cacd0843c12a529e7f3dc501ed.tar.gz
sysvinit-inittab: Fix getting tty device name from SERIAL_CONSOLES entries
Currently the part after "tty" in the device name go into label along with everything after that part. For example if SERIAL_CONSOLES="115200;vt100;ttyS0" than label=S0 but if SERIAL_CONSOLES="115200;ttyS0;vt100" than label=S0;vt100. If SERIAL_CONSOLES="..;ttyX;..", part after 'X' should also be trimmed. Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/sysvinit')
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index 23c284d131..05ba410441 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -22,7 +22,7 @@ do_install() {
for i in $tmp
do
j=`echo ${i} | sed s/\;/\ /g`
- label=`echo ${i} | sed -e 's/^.*;tty//'`
+ label=`echo ${i} | sed -e 's/^.*;tty//' -e 's/;.*//'`
echo "$label:12345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
done