aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/sysvinit
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-09-11 12:56:53 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 15:13:41 +0100
commitbb330fdc0076a043694f1fc4b65b345b604afc36 (patch)
tree1ecc095557d73e9a3735ba98357cb4b8ff8a7f82 /meta/recipes-core/sysvinit
parent1d3391b84f6d9ac538e024da852ea7ff49203add (diff)
downloadopenembedded-core-contrib-bb330fdc0076a043694f1fc4b65b345b604afc36.tar.gz
sysvinit-inittab_2.88dsf.bb: only run serial checks at boot if we have items to check
Right now, we delay running the serial console checks to we boot up. This causes issues for read only file systems. So, if have not configured any serial ports to check via SERIAL_CONSOLES_CHECK we can skip the check at boot. This fixes any issues with read only file systems and ipk packaging. (From OE-Core rev: 019a95a5e01bd3fefaaab0a27029ed8b26ee3c79) Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/sysvinit')
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index 1089edbcb4..5b79caffc2 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Inittab for sysvinit"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r7"
+PR = "r8"
SRC_URI = "file://inittab"
@@ -54,7 +54,7 @@ EOF
pkg_postinst_${PN} () {
# run this on the target
-if [ "x$D" == "x" ]; then
+if [ "x$D" = "x" ]; then
tmp="${SERIAL_CONSOLES_CHECK}"
for i in $tmp
do
@@ -65,7 +65,11 @@ if [ "x$D" == "x" ]; then
done
kill -HUP 1
else
- exit 1
+ if [ "${SERIAL_CONSOLES_CHECK}" = "" ]; then
+ exit 0
+ else
+ exit 1
+ fi
fi
}