aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-01-03 09:48:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-04 12:54:43 +0000
commitfeed576321dcba2d75c067d6ee8b8dad817e9bba (patch)
tree8b0cacccc6badf9dcaea0a743e584cebd3b577da /meta/recipes-core/systemd
parent55d3aeb2d82c907a9ecd35848353c6fcb1f1e45a (diff)
downloadopenembedded-core-contrib-feed576321dcba2d75c067d6ee8b8dad817e9bba.tar.gz
systemd-boot: fix build with musl and x32
systemd-boot shouldn't be built for x32. Make sure that this is the case when TCLIBC is set to something other than glibc. Fixes [YOCTO #12122] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_234.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_234.bb b/meta/recipes-core/systemd/systemd-boot_234.bb
index 7b18b25e35..88a14ac61e 100644
--- a/meta/recipes-core/systemd/systemd-boot_234.bb
+++ b/meta/recipes-core/systemd/systemd-boot_234.bb
@@ -21,7 +21,7 @@ EXTRA_OECONF = " --enable-gnuefi \
# Imported from the old gummiboot recipe
TUNE_CCARGS_remove = "-mfpmath=sse"
COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
-COMPATIBLE_HOST_linux-gnux32 = "null"
+COMPATIBLE_HOST_x86-x32 = "null"
do_compile() {
SYSTEMD_BOOT_EFI_ARCH="ia32"