aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-03-22 15:47:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-25 09:33:36 +0100
commit7409d2d48b69adcdf039fb4aa8bd9ed62460daa9 (patch)
tree0abd40b2c1b8d47cda916f46c820b6c6e69c5a43 /meta/recipes-core/systemd
parentda7fc569e547b4105b00c11a0b41b70230bacc50 (diff)
downloadopenembedded-core-contrib-7409d2d48b69adcdf039fb4aa8bd9ed62460daa9.tar.gz
systemd: link udev statically with systemd internal libraries
This was the default behavior with autotools, but is not with meson. Otherwise, udev package will pull in the rest of systemd even that is not desired. [YOCTO #12618] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd_237.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_237.bb b/meta/recipes-core/systemd/systemd_237.bb
index b1c976fc5b..7ef42b2eae 100644
--- a/meta/recipes-core/systemd/systemd_237.bb
+++ b/meta/recipes-core/systemd/systemd_237.bb
@@ -168,6 +168,11 @@ rootprefix ?= "${root_prefix}"
rootlibdir ?= "${base_libdir}"
rootlibexecdir = "${rootprefix}/lib"
+# This links udev statically with systemd helper library.
+# Otherwise udev package would depend on systemd package (which has the needed shared library),
+# and always pull it into images.
+EXTRA_OEMESON += "-Dlink-udev-shared=false"
+
EXTRA_OEMESON += "-Dnobody-user=nobody \
-Dnobody-group=nobody \
-Droothomedir=${ROOTHOME} \