aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-01-21 18:09:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 18:56:02 +0000
commit192efd033c38205e114f62e9f62696a9a49b0970 (patch)
tree33a3291c4748a54215a9d71976d57d04fba3be39 /meta/recipes-core/systemd
parente5820f56becb3bcee44a461f7fc5640159679a15 (diff)
downloadopenembedded-core-contrib-192efd033c38205e114f62e9f62696a9a49b0970.tar.gz
systemd-serialgetty: skip package when not using systemd
As this package RDEPENDS on systemd it wants to build systemd, but if systemd isn't a DISTRO_FEATURE then that package is skipped so world builds fail. Solve this by skipping this package too. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 3e2a0e36f5..96cbf31470 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -40,3 +40,9 @@ RDEPENDS_${PN} = "systemd"
# This is a machine specific file
FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# As this package is tied to systemd, only build it when we're also building systemd.
+python () {
+ if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
+ raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+}