aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorandreas.kling@peiker-cee.de <andreas.kling@peiker-cee.de>2017-09-27 11:40:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-10-06 12:03:32 +0100
commite1bbca2b6d2edbea0939cbeafe6e74c1d4c59a25 (patch)
tree7b1cf288c9e3d5d8c71a76c1566d423353f0e99d /meta/recipes-core/systemd
parent1a90c97616698050529e169a83e6f07a255687df (diff)
downloadopenembedded-core-contrib-e1bbca2b6d2edbea0939cbeafe6e74c1d4c59a25.tar.gz
systemd: add runtime dependencies to pam plugins.
Signed-off-by: Andy Kling <andreas.kling@peiker-cee.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 881896bfb5..acc4c4623b 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -31,6 +31,12 @@ SRC_URI += " \
"
SRC_URI_append_qemuall = " file://0001-core-device.c-Change-the-default-device-timeout-to-2.patch"
+PAM_PLUGINS = " \
+ pam-plugin-unix \
+ pam-plugin-loginuid \
+ pam-plugin-keyinit \
+"
+
PACKAGECONFIG ??= "xz \
${@bb.utils.filter('DISTRO_FEATURES', 'efi pam selinux ldconfig usrmerge', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)} \
@@ -100,7 +106,7 @@ PACKAGECONFIG[importd] = "--enable-importd,--disable-importd"
PACKAGECONFIG[libidn] = "--enable-libidn,--disable-libidn,libidn"
PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit"
PACKAGECONFIG[manpages] = "--enable-manpages,--disable-manpages,libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
-PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
+PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam,${PAM_PLUGINS}"
# Verify keymaps on locale change
PACKAGECONFIG[xkbcommon] = "--enable-xkbcommon,--disable-xkbcommon,libxkbcommon"
# Update NAT firewall rules
@@ -295,7 +301,6 @@ PACKAGES =+ "\
${PN}-kernel-install \
${PN}-rpm-macros \
${PN}-binfmt \
- ${PN}-pam \
${PN}-zsh-completion \
${PN}-xorg-xinitrc \
${PN}-container \